aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Gopher
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-04-07 15:04:44 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-04-07 15:04:44 +0000
commit45a5f7c4b4e60fc60932d0c503a13150ed7a1ba7 (patch)
treec9d99842e3f712cc617a00d5ee71b474ce4336a6 /net/p5-Net-Gopher
parent1abda59b82d1c97848208fb95e56c9259ac94d12 (diff)
downloadports-45a5f7c4b4e60fc60932d0c503a13150ed7a1ba7.tar.gz
ports-45a5f7c4b4e60fc60932d0c503a13150ed7a1ba7.zip
Notes
Diffstat (limited to 'net/p5-Net-Gopher')
-rw-r--r--net/p5-Net-Gopher/Makefile37
-rw-r--r--net/p5-Net-Gopher/distinfo2
-rw-r--r--net/p5-Net-Gopher/files/patch-Makefile.PL11
-rw-r--r--net/p5-Net-Gopher/pkg-descr4
-rw-r--r--net/p5-Net-Gopher/pkg-plist16
5 files changed, 70 insertions, 0 deletions
diff --git a/net/p5-Net-Gopher/Makefile b/net/p5-Net-Gopher/Makefile
new file mode 100644
index 000000000000..6b31cdf25096
--- /dev/null
+++ b/net/p5-Net-Gopher/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Net-Gopher
+# Date created: 2004-03-31
+# Whom: Toni Viemero <toni.viemero@iki.fi>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Gopher
+PORTVERSION= 1.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= toni.viemero@iki.fi
+COMMENT= Net::Gopher is the Perl Gopher/Gopher+ API
+
+RUN_DEPENDS= ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Gopher.3 \
+ Net::Gopher::Constants.3 \
+ Net::Gopher::Request.3 \
+ Net::Gopher::Response.3 \
+ Net::Gopher::Response::InformationBlock.3 \
+ Net::Gopher::Response::MenuItem.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Socket.pm:${PORTSDIR}/devel/p5-IO
+BUILD_DEPENDS= ${RUN_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Gopher/distinfo b/net/p5-Net-Gopher/distinfo
new file mode 100644
index 000000000000..9a32ad72fc6a
--- /dev/null
+++ b/net/p5-Net-Gopher/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-Gopher-1.05.tar.gz) = 20f3c1628fed59a2b626c13d5de3589f
+SIZE (Net-Gopher-1.05.tar.gz) = 90018
diff --git a/net/p5-Net-Gopher/files/patch-Makefile.PL b/net/p5-Net-Gopher/files/patch-Makefile.PL
new file mode 100644
index 000000000000..db3b16598d55
--- /dev/null
+++ b/net/p5-Net-Gopher/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig Sun Mar 21 19:09:20 2004
++++ Makefile.PL Wed Apr 7 22:56:11 2004
+@@ -7,7 +7,7 @@
+ # don't prompt the user if we're not being called interactively (e.g., if we're
+ # being called from cron or some such program instead of directly by the user):
+ my $interactive = 1;
+-$interactive = 1 if (-t STDIN and -t STDOUT);
++$interactive = 0 if (-t STDIN and -t STDOUT);
+
+ # first, make sure the line endings in the test items are correct:
+ my %files_and_newlines = (
diff --git a/net/p5-Net-Gopher/pkg-descr b/net/p5-Net-Gopher/pkg-descr
new file mode 100644
index 000000000000..77d407f4d52f
--- /dev/null
+++ b/net/p5-Net-Gopher/pkg-descr
@@ -0,0 +1,4 @@
+Net::Gopher is the Perl Gopher/Gopher+ API. This library will enable you to
+communicate with Gopher and Gopher+ servers using Perl.
+
+ WWW: http://search.cpan.org/dist/Net-Gopher/
diff --git a/net/p5-Net-Gopher/pkg-plist b/net/p5-Net-Gopher/pkg-plist
new file mode 100644
index 000000000000..46a1e11a2e87
--- /dev/null
+++ b/net/p5-Net-Gopher/pkg-plist
@@ -0,0 +1,16 @@
+%%SITE_PERL%%/Net/Gopher.pm
+%%SITE_PERL%%/Net/Gopher/Constants.pm
+%%SITE_PERL%%/Net/Gopher/Debugging.pm
+%%SITE_PERL%%/Net/Gopher/Exception.pm
+%%SITE_PERL%%/Net/Gopher/Request.pm
+%%SITE_PERL%%/Net/Gopher/Response.pm
+%%SITE_PERL%%/Net/Gopher/Response/InformationBlock.pm
+%%SITE_PERL%%/Net/Gopher/Response/MenuItem.pm
+%%SITE_PERL%%/Net/Gopher/Utility.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Gopher/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Gopher
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Net/Gopher/Response
+@dirrm %%SITE_PERL%%/Net/Gopher
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true