aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-HTTP
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2011-04-15 07:57:08 +0000
committerFrederic Culot <culot@FreeBSD.org>2011-04-15 07:57:08 +0000
commit04386b5e0c0974e987fcd88ba96b4bb677b3765b (patch)
tree781705171865911bff6d0ebcba47934455fa6585 /net/p5-Net-HTTP
parent454e6d2aa924c18b40b710917b2991e81e09358c (diff)
downloadports-04386b5e0c0974e987fcd88ba96b4bb677b3765b.tar.gz
ports-04386b5e0c0974e987fcd88ba96b4bb677b3765b.zip
Notes
Diffstat (limited to 'net/p5-Net-HTTP')
-rw-r--r--net/p5-Net-HTTP/Makefile27
-rw-r--r--net/p5-Net-HTTP/distinfo2
-rw-r--r--net/p5-Net-HTTP/pkg-descr5
-rw-r--r--net/p5-Net-HTTP/pkg-plist9
4 files changed, 43 insertions, 0 deletions
diff --git a/net/p5-Net-HTTP/Makefile b/net/p5-Net-HTTP/Makefile
new file mode 100644
index 000000000000..431f585c5c7e
--- /dev/null
+++ b/net/p5-Net-HTTP/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-HTTP
+# Date created: 2011-04-15
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-HTTP
+PORTVERSION= 6.00
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Low-level HTTP client
+
+RUN_DEPENDS= p5-Compress-Raw-Zlib>=0:${PORTSDIR}/archivers/p5-Compress-Raw-Zlib \
+ p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress \
+ p5-IO-Socket-SSL>=1.38:${PORTSDIR}/security/p5-IO-Socket-SSL
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+MAN3= Net::HTTP.3 \
+ Net::HTTP::NB.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-HTTP/distinfo b/net/p5-Net-HTTP/distinfo
new file mode 100644
index 000000000000..ad42fb738235
--- /dev/null
+++ b/net/p5-Net-HTTP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-HTTP-6.00.tar.gz) = e711ea7ade65f7543de0eb59676b2ac93beb07fdca1070c64d7c21e556cdd7af
+SIZE (Net-HTTP-6.00.tar.gz) = 13417
diff --git a/net/p5-Net-HTTP/pkg-descr b/net/p5-Net-HTTP/pkg-descr
new file mode 100644
index 000000000000..f7c0c94f6470
--- /dev/null
+++ b/net/p5-Net-HTTP/pkg-descr
@@ -0,0 +1,5 @@
+The Net::HTTP class is a low-level HTTP client that supports
+HTTP/1.0 and HTTP/1.1. An instance of the Net::HTTP class
+represents a connection to an HTTP server.
+
+WWW: http://search.cpan.org/dist/Net-HTTP/
diff --git a/net/p5-Net-HTTP/pkg-plist b/net/p5-Net-HTTP/pkg-plist
new file mode 100644
index 000000000000..1ad3d7da6b52
--- /dev/null
+++ b/net/p5-Net-HTTP/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Net/HTTP.pm
+%%SITE_PERL%%/Net/HTTPS.pm
+%%SITE_PERL%%/Net/HTTP/Methods.pm
+%%SITE_PERL%%/Net/HTTP/NB.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/HTTP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/HTTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/HTTP
+@dirrmtry %%SITE_PERL%%/Net