aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-IPTrie
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2007-12-14 14:01:29 +0000
committerAnton Berezin <tobez@FreeBSD.org>2007-12-14 14:01:29 +0000
commit68330ebefd0059158c4119823090dff824cdadaf (patch)
tree854bbfb6030f59842d149dcc08fde9824385b74d /net/p5-Net-IPTrie
parent68381b3ee80e29fa9cd6d08bcf9e9c6947292d70 (diff)
downloadports-68330ebefd0059158c4119823090dff824cdadaf.tar.gz
ports-68330ebefd0059158c4119823090dff824cdadaf.zip
Notes
Diffstat (limited to 'net/p5-Net-IPTrie')
-rw-r--r--net/p5-Net-IPTrie/Makefile27
-rw-r--r--net/p5-Net-IPTrie/distinfo3
-rw-r--r--net/p5-Net-IPTrie/pkg-descr7
-rw-r--r--net/p5-Net-IPTrie/pkg-plist4
4 files changed, 41 insertions, 0 deletions
diff --git a/net/p5-Net-IPTrie/Makefile b/net/p5-Net-IPTrie/Makefile
new file mode 100644
index 000000000000..1ca290c044f0
--- /dev/null
+++ b/net/p5-Net-IPTrie/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Net-IPTrie
+# Date created: 13 December 2007
+# Whom: Matthew Luckie <mjl@luckie.org.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-IPTrie
+PORTVERSION= 0.3
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= mjl@luckie.org.nz
+COMMENT= Module for building IPv4 and IPv6 address space hierarchies
+
+BUILD_DEPENDS= p5-NetAddr-IP>=4.00.7:${PORTSDIR}/net-mgmt/p5-NetAddr-IP \
+ p5-version>=0:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= 5.8.0+
+
+MAN3= Net::IPTrie.3 Net::IPTrie::Node.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-IPTrie/distinfo b/net/p5-Net-IPTrie/distinfo
new file mode 100644
index 000000000000..644a504c734e
--- /dev/null
+++ b/net/p5-Net-IPTrie/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-IPTrie-v0.3.tar.gz) = 8fd4e5fbbf97ccef6b5ad5c719f9f151
+SHA256 (Net-IPTrie-v0.3.tar.gz) = 01724dc2d143f9bc20fff49015c12d543dc72541b40669be5902a9657fd3a4a1
+SIZE (Net-IPTrie-v0.3.tar.gz) = 6317
diff --git a/net/p5-Net-IPTrie/pkg-descr b/net/p5-Net-IPTrie/pkg-descr
new file mode 100644
index 000000000000..2a5b63dc88a6
--- /dev/null
+++ b/net/p5-Net-IPTrie/pkg-descr
@@ -0,0 +1,7 @@
+This module uses a radix tree (or trie) to quickly build the hierarchy of a
+given address space (both IPv4 and IPv6). This allows the user to perform
+fast subnet or routing lookups.
+
+It is implemented exclusively in Perl.
+
+WWW: http://search.cpan.org/dist/Net-IPTrie/
diff --git a/net/p5-Net-IPTrie/pkg-plist b/net/p5-Net-IPTrie/pkg-plist
new file mode 100644
index 000000000000..279ee7cb0a08
--- /dev/null
+++ b/net/p5-Net-IPTrie/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Net/IPTrie.pm
+%%SITE_PERL%%/Net/IPTrie/Node.pm
+@dirrm %%SITE_PERL%%/Net/IPTrie
+@dirrmtry %%SITE_PERL%%/Net