aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-LDAP-posixAccount
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-03 16:59:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-03 16:59:38 +0000
commit05830cc6e25e327f5df55e12c011553ba89b18ed (patch)
treebed395e1205c918522bd0641b277516eae259626 /net/p5-Net-LDAP-posixAccount
parent1570c14eed5f023ec0265cb4f5fb61aa7820b7bb (diff)
Notes
Diffstat (limited to 'net/p5-Net-LDAP-posixAccount')
-rw-r--r--net/p5-Net-LDAP-posixAccount/Makefile26
-rw-r--r--net/p5-Net-LDAP-posixAccount/distinfo3
-rw-r--r--net/p5-Net-LDAP-posixAccount/pkg-descr3
-rw-r--r--net/p5-Net-LDAP-posixAccount/pkg-plist7
4 files changed, 39 insertions, 0 deletions
diff --git a/net/p5-Net-LDAP-posixAccount/Makefile b/net/p5-Net-LDAP-posixAccount/Makefile
new file mode 100644
index 000000000000..aaa1e1bb4053
--- /dev/null
+++ b/net/p5-Net-LDAP-posixAccount/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: sysutils/p5-Net-LDAP-posixAccount
+# Date created: 2009-10-31
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-LDAP-posixAccount
+PORTVERSION= 0.0.2
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/V/VV/VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Creates new Net::LDAP::Entry objects for a posixAccount entry
+
+RUN_DEPENDS= ${SITE_PERL}/Net/LDAP/Entry.pm:${PORTSDIR}/net/p5-perl-ldap \
+ ${SITE_PERL}/Sys/User/UIDhelper.pm:${PORTSDIR}/sysutils/p5-Sys-User-UIDhelper \
+ ${SITE_PERL}/Sys/Group/GIDhelper.pm:${PORTSDIR}/sysutils/p5-Sys-Group-GIDhelper
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::LDAP::posixAccount.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-LDAP-posixAccount/distinfo b/net/p5-Net-LDAP-posixAccount/distinfo
new file mode 100644
index 000000000000..93bc62595db1
--- /dev/null
+++ b/net/p5-Net-LDAP-posixAccount/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-LDAP-posixAccount-0.0.2.tar.gz) = 38fe2d2b70f6bab09a5aafebb367d164
+SHA256 (Net-LDAP-posixAccount-0.0.2.tar.gz) = 315408fdd3f32961f84d84952dd16742841682731b18bdf4f71998d68c4156b8
+SIZE (Net-LDAP-posixAccount-0.0.2.tar.gz) = 4665
diff --git a/net/p5-Net-LDAP-posixAccount/pkg-descr b/net/p5-Net-LDAP-posixAccount/pkg-descr
new file mode 100644
index 000000000000..4de3a1d87af4
--- /dev/null
+++ b/net/p5-Net-LDAP-posixAccount/pkg-descr
@@ -0,0 +1,3 @@
+Creates new Net::LDAP::Entry objects for a posixAccount entry.
+
+WWW: http://search.cpan.org/dist/Net-LDAP-posixAccount/
diff --git a/net/p5-Net-LDAP-posixAccount/pkg-plist b/net/p5-Net-LDAP-posixAccount/pkg-plist
new file mode 100644
index 000000000000..de1a70eccfb1
--- /dev/null
+++ b/net/p5-Net-LDAP-posixAccount/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/LDAP/posixAccount.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP/posixAccount/.packlist
+@dirrmtry %%SITE_PERL%%/Net/LDAP/
+@dirrmtry %%SITE_PERL%%/Net/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP/posixAccount/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/LDAP/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/