aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-MAC-Vendor/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-25 22:25:43 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-25 22:25:43 +0000
commitfab0f8ee45620404534275c3540e586a008786b1 (patch)
tree7b560cfa05b15f2d7daa30c8ef70083bd1ddae48 /net/p5-Net-MAC-Vendor/Makefile
parentef6445d066b1c16347b49e2f079bb90d75525865 (diff)
Notes
Diffstat (limited to 'net/p5-Net-MAC-Vendor/Makefile')
-rw-r--r--net/p5-Net-MAC-Vendor/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/p5-Net-MAC-Vendor/Makefile b/net/p5-Net-MAC-Vendor/Makefile
new file mode 100644
index 000000000000..f85c935df980
--- /dev/null
+++ b/net/p5-Net-MAC-Vendor/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Net-MAC-Vendor
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-MAC-Vendor
+PORTVERSION= 1.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Look up the vendor for a MAC
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+
+MAN3= Net::MAC::Vendor.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>