aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-MAC-Vendor
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-25 22:25:43 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-25 22:25:43 +0000
commitfab0f8ee45620404534275c3540e586a008786b1 (patch)
tree7b560cfa05b15f2d7daa30c8ef70083bd1ddae48 /net/p5-Net-MAC-Vendor
parentef6445d066b1c16347b49e2f079bb90d75525865 (diff)
downloadports-fab0f8ee45620404534275c3540e586a008786b1.tar.gz
ports-fab0f8ee45620404534275c3540e586a008786b1.zip
Notes
Diffstat (limited to 'net/p5-Net-MAC-Vendor')
-rw-r--r--net/p5-Net-MAC-Vendor/Makefile30
-rw-r--r--net/p5-Net-MAC-Vendor/distinfo3
-rw-r--r--net/p5-Net-MAC-Vendor/pkg-descr24
-rw-r--r--net/p5-Net-MAC-Vendor/pkg-plist7
4 files changed, 64 insertions, 0 deletions
diff --git a/net/p5-Net-MAC-Vendor/Makefile b/net/p5-Net-MAC-Vendor/Makefile
new file mode 100644
index 000000000000..f85c935df980
--- /dev/null
+++ b/net/p5-Net-MAC-Vendor/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Net-MAC-Vendor
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-MAC-Vendor
+PORTVERSION= 1.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Look up the vendor for a MAC
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+
+MAN3= Net::MAC::Vendor.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-MAC-Vendor/distinfo b/net/p5-Net-MAC-Vendor/distinfo
new file mode 100644
index 000000000000..91ad9cdab51d
--- /dev/null
+++ b/net/p5-Net-MAC-Vendor/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-MAC-Vendor-1.01.tar.gz) = c3f16ae1be735fa76facacd191e8c0ba
+SHA256 (Net-MAC-Vendor-1.01.tar.gz) = a3a14fa709c1328c92c675e8c15758b3a7b7781171bf110fb16592c94886f36f
+SIZE (Net-MAC-Vendor-1.01.tar.gz) = 5962
diff --git a/net/p5-Net-MAC-Vendor/pkg-descr b/net/p5-Net-MAC-Vendor/pkg-descr
new file mode 100644
index 000000000000..1f75f64e0fcb
--- /dev/null
+++ b/net/p5-Net-MAC-Vendor/pkg-descr
@@ -0,0 +1,24 @@
+The Institute of Electrical and Electronics Engineers (IEEE) assigns an
+Organizational Unique Identifier (OUI) to manufacturers of network
+interfaces. Each interface has a Media Access Control (MAC) address of six
+bytes. The first three bytes are the OUI.
+
+This module allows you to take a MAC address and turn it into the OUI and
+vendor information. You can, for instance, scan a network, collect MAC
+addresses, and turn those addresses into vendors. With vendor information,
+you can often guess at what what you are looking at (e.g. an Apple
+product).
+
+You can use this as a module as its individual functions, or call it as a
+script with a list of MAC addresses as arguments. The module can figure it
+out.
+
+This module tries to persistently cache with DBM::Deep the OUI information
+so it can avoid using the network. If it cannot load DBM::Deep, it uses a
+normal hash (which is lost when the process finishes). You can preload
+this cache with the load_cache() function. So far, the module looks in the
+current working directory for a file named mac_oui.db to find the cache. I
+need to come up with a way to let the user set that location.
+
+WWW: http://search.cpan.org/dist/Net-MAC-Vendor
+Author: brian d foy <bdfoy@cpan.org>
diff --git a/net/p5-Net-MAC-Vendor/pkg-plist b/net/p5-Net-MAC-Vendor/pkg-plist
new file mode 100644
index 000000000000..64b9135ba76a
--- /dev/null
+++ b/net/p5-Net-MAC-Vendor/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/MAC/Vendor.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MAC/Vendor/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MAC/Vendor
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MAC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/MAC
+@dirrmtry %%SITE_PERL%%/Net