aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-MAC
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-10-25 19:09:50 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-10-25 19:09:50 +0000
commit23b70faef93d747adaeea28cd37290057ca8dc7e (patch)
tree0f7fd4f12dd122f4b7daace2089828e4eada8b42 /net/p5-Net-MAC
parent1085424bf562144573976204cf87f2bae26d3cc4 (diff)
downloadports-23b70faef93d747adaeea28cd37290057ca8dc7e.tar.gz
ports-23b70faef93d747adaeea28cd37290057ca8dc7e.zip
Notes
Diffstat (limited to 'net/p5-Net-MAC')
-rw-r--r--net/p5-Net-MAC/Makefile24
-rw-r--r--net/p5-Net-MAC/distinfo3
-rw-r--r--net/p5-Net-MAC/pkg-descr7
-rw-r--r--net/p5-Net-MAC/pkg-plist6
4 files changed, 40 insertions, 0 deletions
diff --git a/net/p5-Net-MAC/Makefile b/net/p5-Net-MAC/Makefile
new file mode 100644
index 000000000000..4c0db289a04b
--- /dev/null
+++ b/net/p5-Net-MAC/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Net-MAC
+# Date created: 25 Oct 2008
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-MAC
+PORTVERSION= 1.4
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Perl 5 module for representing and manipulating MAC addresses
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+
+MAN3= Net::MAC.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-MAC/distinfo b/net/p5-Net-MAC/distinfo
new file mode 100644
index 000000000000..35d37f0d5524
--- /dev/null
+++ b/net/p5-Net-MAC/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-MAC-1.4.tar.gz) = b0f416a678efe23bcc49bc502b978c0c
+SHA256 (Net-MAC-1.4.tar.gz) = efaa1486156724705d2c5cc4b73f9145e0f5356b2e492269f019a8a611b4aaa1
+SIZE (Net-MAC-1.4.tar.gz) = 29475
diff --git a/net/p5-Net-MAC/pkg-descr b/net/p5-Net-MAC/pkg-descr
new file mode 100644
index 000000000000..fd0a1fbd8304
--- /dev/null
+++ b/net/p5-Net-MAC/pkg-descr
@@ -0,0 +1,7 @@
+The Perl 5 module Net::MAC allows you to
+ - store a MAC address in a Perl object
+ - find out information about a stored MAC address
+ - convert a MAC address into a specified format
+ - easily compare two MAC addresses for string or numeric equality
+
+ WWW: http://search.cpan.org/dist/Net-MAC/
diff --git a/net/p5-Net-MAC/pkg-plist b/net/p5-Net-MAC/pkg-plist
new file mode 100644
index 000000000000..7fcc6396f8ea
--- /dev/null
+++ b/net/p5-Net-MAC/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Net/MAC.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MAC/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/MAC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrmtry %%SITE_PERL%%/Net