aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-OAuth
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-10-24 10:22:06 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-10-24 10:22:06 +0000
commit55f7e62fab6c76ebdacc5c19932886398c94aa38 (patch)
tree94c0a628f5cdf68664d1c2784bf48163bbb9ebd5 /net/p5-Net-OAuth
parenta1a6665b38a2cc82512ddd2ad8a87d7e8fda5e62 (diff)
downloadports-55f7e62fab6c76ebdacc5c19932886398c94aa38.tar.gz
ports-55f7e62fab6c76ebdacc5c19932886398c94aa38.zip
Notes
Diffstat (limited to 'net/p5-Net-OAuth')
-rw-r--r--net/p5-Net-OAuth/Makefile35
-rw-r--r--net/p5-Net-OAuth/distinfo3
-rw-r--r--net/p5-Net-OAuth/pkg-descr9
-rw-r--r--net/p5-Net-OAuth/pkg-plist10
4 files changed, 57 insertions, 0 deletions
diff --git a/net/p5-Net-OAuth/Makefile b/net/p5-Net-OAuth/Makefile
new file mode 100644
index 000000000000..7cae66dc7c7f
--- /dev/null
+++ b/net/p5-Net-OAuth/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: Net::OAuth
+# Date created: Oct 24, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OAuth
+PORTVERSION= 0.04
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= An implementation of the OAuth protocol
+
+BUILD_DEPENDS= p5-UNIVERSAL-require>=0.10:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ p5-Digest-HMAC>=1.01:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
+ p5-Class-Accessor>=0.31:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>=0.06:${PORTSDIR}/devel/p5-Class-Data-Inheritable
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Net::OAuth::AccessTokenRequest.3 \
+ Net::OAuth::ProtectedResourceRequest.3 \
+ Net::OAuth::Request.3 \
+ Net::OAuth::RequestTokenRequest.3 \
+ Net::OAuth::SignatureMethod::HMAC_SHA1.3 \
+ Net::OAuth::SignatureMethod::PLAINTEXT.3 \
+ Net::OAuth::SignatureMethod::RSA_SHA1.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-OAuth/distinfo b/net/p5-Net-OAuth/distinfo
new file mode 100644
index 000000000000..c1780ccdcaa9
--- /dev/null
+++ b/net/p5-Net-OAuth/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-OAuth-0.04.tar.gz) = 00fa3f832a2fcc14dfcdb43e5df85382
+SHA256 (Net-OAuth-0.04.tar.gz) = 415ae5b4261a23c9da25e1e52e7fe41d0b48554219474353e50fe4465d1fbb84
+SIZE (Net-OAuth-0.04.tar.gz) = 7669
diff --git a/net/p5-Net-OAuth/pkg-descr b/net/p5-Net-OAuth/pkg-descr
new file mode 100644
index 000000000000..ef03854a0cb6
--- /dev/null
+++ b/net/p5-Net-OAuth/pkg-descr
@@ -0,0 +1,9 @@
+Net::OAuth is an implementation of the OAuth protocol.
+
+OAuth is:
+
+An open protocol to allow secure API authentication in a simple and standard
+method from desktop and web applications.
+
+WWW: http://oauth.net/
+WWW: http://search.cpan.org/dist/Net-OAuth/
diff --git a/net/p5-Net-OAuth/pkg-plist b/net/p5-Net-OAuth/pkg-plist
new file mode 100644
index 000000000000..92952ed4a158
--- /dev/null
+++ b/net/p5-Net-OAuth/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Net/OAuth/AccessTokenRequest.pm
+%%SITE_PERL%%/Net/OAuth/ProtectedResourceRequest.pm
+%%SITE_PERL%%/Net/OAuth/Request.pm
+%%SITE_PERL%%/Net/OAuth/RequestTokenRequest.pm
+%%SITE_PERL%%/Net/OAuth/SignatureMethod/HMAC_SHA1.pm
+%%SITE_PERL%%/Net/OAuth/SignatureMethod/PLAINTEXT.pm
+%%SITE_PERL%%/Net/OAuth/SignatureMethod/RSA_SHA1.pm
+@dirrm %%SITE_PERL%%/Net/OAuth/SignatureMethod
+@dirrm %%SITE_PERL%%/Net/OAuth
+@dirrmtry %%SITE_PERL%%/Net