aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-OpenDHT/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-25 08:32:10 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-25 08:32:10 +0000
commit78059d78f262d7fc3f2925fdfaa143f655cb867c (patch)
tree34679bf419476db8b133d3ae517064b424b9a2ae /net/p5-Net-OpenDHT/Makefile
parent7072e9fefe69819fb31f2f031dd6958a19222317 (diff)
Notes
Diffstat (limited to 'net/p5-Net-OpenDHT/Makefile')
-rw-r--r--net/p5-Net-OpenDHT/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/p5-Net-OpenDHT/Makefile b/net/p5-Net-OpenDHT/Makefile
new file mode 100644
index 000000000000..e7b1ca21a8ec
--- /dev/null
+++ b/net/p5-Net-OpenDHT/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Net-OpenDHT
+# Date created: 21 May 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-OpenDHT
+PORTVERSION= 0.29
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Access the Open Distributed Hash Table (Open DHT)
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Chained/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor-Chained \
+ ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::OpenDHT.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Perl 5.6 or greater required. Please install lang/perl5 or lang/perl5.8
+.endif
+
+.include <bsd.port.post.mk>