aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-OpenID-Consumer
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-11-11 08:21:41 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-11-11 08:21:41 +0000
commitb98b4c2587f113fe496a0e10cb936b89c239ee73 (patch)
treed57ba756bf8bd164006d84b2099352b12c009c21 /net/p5-Net-OpenID-Consumer
parent6d9783bec49896513a6de8fc00b30a04172bfc0a (diff)
downloadports-b98b4c2587f113fe496a0e10cb936b89c239ee73.tar.gz
ports-b98b4c2587f113fe496a0e10cb936b89c239ee73.zip
Notes
Diffstat (limited to 'net/p5-Net-OpenID-Consumer')
-rw-r--r--net/p5-Net-OpenID-Consumer/Makefile8
-rw-r--r--net/p5-Net-OpenID-Consumer/distinfo6
-rw-r--r--net/p5-Net-OpenID-Consumer/files/patch-Consumer.pm18
-rw-r--r--net/p5-Net-OpenID-Consumer/pkg-plist5
4 files changed, 16 insertions, 21 deletions
diff --git a/net/p5-Net-OpenID-Consumer/Makefile b/net/p5-Net-OpenID-Consumer/Makefile
index d9a6ced35bbc..399210b91e38 100644
--- a/net/p5-Net-OpenID-Consumer/Makefile
+++ b/net/p5-Net-OpenID-Consumer/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= Net-OpenID-Consumer
-PORTVERSION= 0.14
-PORTREVISION= 1
+PORTVERSION= 1.02
CATEGORIES= net security perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= Net
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
@@ -26,7 +24,9 @@ BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Net::OpenID::Association.3 Net::OpenID::ClaimedIdentity.3 \
- Net::OpenID::Consumer.3 Net::OpenID::VerifiedIdentity.3
+ Net::OpenID::Consumer.3 Net::OpenID::IndirectMessage.3 \
+ Net::OpenID::URIFetch.3 Net::OpenID::VerifiedIdentity.3 \
+ Net::OpenID::Yadis.3 Net::OpenID::Yadis::Service.3
post-patch:
@${FIND} ${WRKSRC} -type f -name "*.orig" -delete
diff --git a/net/p5-Net-OpenID-Consumer/distinfo b/net/p5-Net-OpenID-Consumer/distinfo
index 18dff003728a..36a28941d3af 100644
--- a/net/p5-Net-OpenID-Consumer/distinfo
+++ b/net/p5-Net-OpenID-Consumer/distinfo
@@ -1,3 +1,3 @@
-MD5 (Net-OpenID-Consumer-0.14.tar.gz) = e57f1510a92e142635589b0343803535
-SHA256 (Net-OpenID-Consumer-0.14.tar.gz) = eb2c5e24556c894f5c554c7e42141bb232df8bf8a78472cfe1bef30fbefc67b6
-SIZE (Net-OpenID-Consumer-0.14.tar.gz) = 17637
+MD5 (Net-OpenID-Consumer-1.02.tar.gz) = 7c94aa0c58460646760973c42bcf6b25
+SHA256 (Net-OpenID-Consumer-1.02.tar.gz) = c51dd1c670f914d4c5a767d282664734ec88aa6697b34944cd60833ef3eec27f
+SIZE (Net-OpenID-Consumer-1.02.tar.gz) = 34049
diff --git a/net/p5-Net-OpenID-Consumer/files/patch-Consumer.pm b/net/p5-Net-OpenID-Consumer/files/patch-Consumer.pm
index cdd5ab0a05f8..290fd1f19039 100644
--- a/net/p5-Net-OpenID-Consumer/files/patch-Consumer.pm
+++ b/net/p5-Net-OpenID-Consumer/files/patch-Consumer.pm
@@ -1,6 +1,6 @@
---- Consumer.pm 2007-08-04 02:38:53.000000000 +0400
-+++ lib/Net/OpenID/Consumer.pm 2008-06-04 19:10:37.000000000 +0400
-@@ -235,7 +235,7 @@
+--- lib/Net/OpenID/Consumer.pm.orig 2008-10-14 12:38:16.000000000 +0800
++++ lib/Net/OpenID/Consumer.pm 2008-11-11 15:20:06.000000000 +0800
+@@ -255,7 +255,7 @@
# OpenID servers / delegated identities
# <link rel="openid.server" href="http://www.livejournal.com/misc/openid.bml" />
if ($type eq "link" &&
@@ -9,17 +9,7 @@
$val =~ m!\bhref=[\"\']([^\"\']+)[\"\']!i) {
$ret->{"openid.$temp"} = $1;
next;
-@@ -301,7 +301,8 @@
- $ret->{$k} =~ s/&(\w+);/$emap->{$1} || ""/eg;
- }
-
-- $self->_debug("semantic info ($url) = " . join(", ", %$ret));
-+ $self->_debug("semantic info ($url) = " . join(", ",
-+ map { defined($ret->{$_}) ? ($_ => $ret->{$_}) : () } keys %$ret));
-
- return $ret;
- }
-@@ -543,6 +544,7 @@
+@@ -909,6 +909,7 @@
sub hmac {
my($data, $key, $hash_func, $block_size) = @_;
$block_size ||= 64;
diff --git a/net/p5-Net-OpenID-Consumer/pkg-plist b/net/p5-Net-OpenID-Consumer/pkg-plist
index 9046c70b7ee9..e9b9e1079e44 100644
--- a/net/p5-Net-OpenID-Consumer/pkg-plist
+++ b/net/p5-Net-OpenID-Consumer/pkg-plist
@@ -3,7 +3,12 @@
%%SITE_PERL%%/Net/OpenID/Association.pm
%%SITE_PERL%%/Net/OpenID/ClaimedIdentity.pm
%%SITE_PERL%%/Net/OpenID/Consumer.pm
+%%SITE_PERL%%/Net/OpenID/IndirectMessage.pm
+%%SITE_PERL%%/Net/OpenID/URIFetch.pm
%%SITE_PERL%%/Net/OpenID/VerifiedIdentity.pm
+%%SITE_PERL%%/Net/OpenID/Yadis.pm
+%%SITE_PERL%%/Net/OpenID/Yadis/Service.pm
+@dirrmtry %%SITE_PERL%%/Net/OpenID/Yadis
@dirrmtry %%SITE_PERL%%/Net/OpenID
@dirrmtry %%SITE_PERL%%/Net
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/Consumer