aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-OpenID-Consumer
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2011-11-10 08:39:28 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2011-11-10 08:39:28 +0000
commitfaf4bd8ab31f8c142b731bde5385effa8baf825b (patch)
tree6d1f2c6a95a162ae3d4e91ff83c4b34acaf211f2 /net/p5-Net-OpenID-Consumer
parent3bd83d70decf61fd0ea5b787a47aa768ba18b257 (diff)
downloadports-faf4bd8ab31f8c142b731bde5385effa8baf825b.tar.gz
ports-faf4bd8ab31f8c142b731bde5385effa8baf825b.zip
Notes
Diffstat (limited to 'net/p5-Net-OpenID-Consumer')
-rw-r--r--net/p5-Net-OpenID-Consumer/Makefile19
-rw-r--r--net/p5-Net-OpenID-Consumer/distinfo4
-rw-r--r--net/p5-Net-OpenID-Consumer/files/patch-Consumer.pm19
-rw-r--r--net/p5-Net-OpenID-Consumer/pkg-plist5
4 files changed, 11 insertions, 36 deletions
diff --git a/net/p5-Net-OpenID-Consumer/Makefile b/net/p5-Net-OpenID-Consumer/Makefile
index 3e5c5da1ac5a..42dfdfe69135 100644
--- a/net/p5-Net-OpenID-Consumer/Makefile
+++ b/net/p5-Net-OpenID-Consumer/Makefile
@@ -6,30 +6,29 @@
#
PORTNAME= Net-OpenID-Consumer
-PORTVERSION= 1.06
+PORTVERSION= 1.12
CATEGORIES= net security perl5
MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= CPAN:GUGU
PKGNAMEPREFIX= p5-
-MAINTAINER= perl@FreeBSD.org
+MAINTAINER= clsung@FreeBSD.org
COMMENT= Library for consumers of OpenID identities
RUN_DEPENDS= p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
- p5-Crypt-DH-GMP>=0.0.5:${PORTSDIR}/net/p5-Crypt-DH-GMP \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
- p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple
+ p5-Net-OpenID-Common>=0:${PORTSDIR}/security/p5-Net-OpenID-Common \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN3= Net::OpenID::Association.3 Net::OpenID::ClaimedIdentity.3 \
- Net::OpenID::Consumer.3 Net::OpenID::IndirectMessage.3 \
- Net::OpenID::URIFetch.3 Net::OpenID::VerifiedIdentity.3 \
- Net::OpenID::Yadis.3 Net::OpenID::Yadis::Service.3
+ Net::OpenID::Consumer.3 Net::OpenID::VerifiedIdentity.3
-post-patch:
- @${FIND} ${WRKSRC} -type f -name "*.orig" -delete
+.if defined(MAINTAINER_MODE)
+regression-test: build
+ cd ${WRKSRC} && ${MAKE} test
+.endif
.include <bsd.port.mk>
diff --git a/net/p5-Net-OpenID-Consumer/distinfo b/net/p5-Net-OpenID-Consumer/distinfo
index 64e7624cbc49..f162cdfb3326 100644
--- a/net/p5-Net-OpenID-Consumer/distinfo
+++ b/net/p5-Net-OpenID-Consumer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Net-OpenID-Consumer-1.06.tar.gz) = ba9002fc19bdddf9c4c144e505f27f63bc21cf4730b599cced2d8d4472a67346
-SIZE (Net-OpenID-Consumer-1.06.tar.gz) = 52402
+SHA256 (Net-OpenID-Consumer-1.12.tar.gz) = 37b8459058b425f3d5c56a08b6cfb82c6997d5f1bf48df0c9c0eeb203b087a12
+SIZE (Net-OpenID-Consumer-1.12.tar.gz) = 56471
diff --git a/net/p5-Net-OpenID-Consumer/files/patch-Consumer.pm b/net/p5-Net-OpenID-Consumer/files/patch-Consumer.pm
deleted file mode 100644
index 290fd1f19039..000000000000
--- a/net/p5-Net-OpenID-Consumer/files/patch-Consumer.pm
+++ /dev/null
@@ -1,19 +0,0 @@
---- lib/Net/OpenID/Consumer.pm.orig 2008-10-14 12:38:16.000000000 +0800
-+++ lib/Net/OpenID/Consumer.pm 2008-11-11 15:20:06.000000000 +0800
-@@ -255,7 +255,7 @@
- # OpenID servers / delegated identities
- # <link rel="openid.server" href="http://www.livejournal.com/misc/openid.bml" />
- if ($type eq "link" &&
-- $val =~ /\brel=.openid\.(server|delegate)./i && ($temp = $1) &&
-+ $val =~ /\brel=[\"\'][^\"\']*\bopenid\.(server|delegate)\b/i && ($temp = $1) &&
- $val =~ m!\bhref=[\"\']([^\"\']+)[\"\']!i) {
- $ret->{"openid.$temp"} = $1;
- next;
-@@ -909,6 +909,7 @@
- sub hmac {
- my($data, $key, $hash_func, $block_size) = @_;
- $block_size ||= 64;
-+ $key = $key . ''; # stringify for charwise ^ to work
- $key = &$hash_func($key) if length($key) > $block_size;
-
- my $k_ipad = $key ^ (chr(0x36) x $block_size);
diff --git a/net/p5-Net-OpenID-Consumer/pkg-plist b/net/p5-Net-OpenID-Consumer/pkg-plist
index 047a1c7d7b78..f373aff2f607 100644
--- a/net/p5-Net-OpenID-Consumer/pkg-plist
+++ b/net/p5-Net-OpenID-Consumer/pkg-plist
@@ -2,12 +2,7 @@
%%SITE_PERL%%/Net/OpenID/Association.pm
%%SITE_PERL%%/Net/OpenID/ClaimedIdentity.pm
%%SITE_PERL%%/Net/OpenID/Consumer.pm
-%%SITE_PERL%%/Net/OpenID/IndirectMessage.pm
-%%SITE_PERL%%/Net/OpenID/URIFetch.pm
%%SITE_PERL%%/Net/OpenID/VerifiedIdentity.pm
-%%SITE_PERL%%/Net/OpenID/Yadis.pm
-%%SITE_PERL%%/Net/OpenID/Yadis/Service.pm
-@dirrmtry %%SITE_PERL%%/Net/OpenID/Yadis
@dirrmtry %%SITE_PERL%%/Net/OpenID
@dirrmtry %%SITE_PERL%%/Net
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/OpenID/Consumer