aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Packet
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2010-01-29 08:02:01 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2010-01-29 08:02:01 +0000
commitb4b91492ac9959577291a8fcd0acb87f0892d906 (patch)
tree0a48af1c8da94bc09add2b24421809c013367d6e /net/p5-Net-Packet
parent8a72835fa106ad8aa40593c5f1e9f5682beb35ed (diff)
downloadports-b4b91492ac9959577291a8fcd0acb87f0892d906.tar.gz
ports-b4b91492ac9959577291a8fcd0acb87f0892d906.zip
Notes
Diffstat (limited to 'net/p5-Net-Packet')
-rw-r--r--net/p5-Net-Packet/Makefile10
-rw-r--r--net/p5-Net-Packet/distinfo6
-rw-r--r--net/p5-Net-Packet/pkg-plist22
3 files changed, 33 insertions, 5 deletions
diff --git a/net/p5-Net-Packet/Makefile b/net/p5-Net-Packet/Makefile
index d8b9773dd995..3737ca4fa237 100644
--- a/net/p5-Net-Packet/Makefile
+++ b/net/p5-Net-Packet/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= Net-Packet
-DISTVERSION= 3.26
-PORTREVISION= 1
+DISTVERSION= 3.27
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -25,6 +24,7 @@ BUILD_DEPENDS= p5-Bit-Vector>=6.4:${PORTSDIR}/math/p5-Bit-Vector \
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
MAN3= Net::Packet.3 Net::Packet::ARP.3 Net::Packet::CDP.3 Net::Packet::CDP::Address.3 \
Net::Packet::CDP::Type.3 Net::Packet::CDP::TypeAddresses.3 Net::Packet::CDP::TypeCapabilities.3 \
@@ -38,4 +38,10 @@ Net::Packet::OSPF.3 Net::Packet::PPP.3 Net::Packet::PPPLCP.3 Net::Packet::PPPoE.
Net::Packet::SLL.3 Net::Packet::STP.3 Net::Packet::TCP.3 Net::Packet::UDP.3 Net::Packet::Utils.3 \
Net::Packet::VLAN.3
+.if !defined(NOPORTEXAMPLES)
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
+.endif
+
.include <bsd.port.mk>
diff --git a/net/p5-Net-Packet/distinfo b/net/p5-Net-Packet/distinfo
index 19e38ce63ce1..c563895921fb 100644
--- a/net/p5-Net-Packet/distinfo
+++ b/net/p5-Net-Packet/distinfo
@@ -1,3 +1,3 @@
-MD5 (Net-Packet-3.26.tar.gz) = 19f7fb5b5b5eb509e44a2a6e189fc2c9
-SHA256 (Net-Packet-3.26.tar.gz) = a719e50746b2646a5a757dadb4f5a9249291f92df5673327116fee185f575b86
-SIZE (Net-Packet-3.26.tar.gz) = 69085
+MD5 (Net-Packet-3.27.tar.gz) = 1f1d0b19b043d47dd30d21d5cf02e1e7
+SHA256 (Net-Packet-3.27.tar.gz) = f8e0754f1ce5acf0f8122d25aa5f60d942e9c6e845d39a4f00fb7b20523b2871
+SIZE (Net-Packet-3.27.tar.gz) = 68831
diff --git a/net/p5-Net-Packet/pkg-plist b/net/p5-Net-Packet/pkg-plist
index 37ec358ca311..242721a2a847 100644
--- a/net/p5-Net-Packet/pkg-plist
+++ b/net/p5-Net-Packet/pkg-plist
@@ -45,3 +45,25 @@
@dirrmtry %%SITE_PERL%%/Net
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Packet
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arp-reply.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arp-request.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/arp-scan.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/chaos-query.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/d3-syn-send.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/d4-syn-send.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp-dest-unreach.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp-echo.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp-information.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp-mask.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp-redirect.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/icmp-timestamp.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ip6-syn-send.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ipv4-flags.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/read-pcap.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sniffer.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/syn-scan.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/syn-send.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/udp-send.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vlan-craft.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/vlan-support.pl
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%