aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Patricia
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>2001-03-13 21:12:21 +0000
committerAndreas Klemm <andreas@FreeBSD.org>2001-03-13 21:12:21 +0000
commit285996cdec4e777695f67857f0f77879b0614258 (patch)
tree21f57361d4f5047a701a148cd983f1f4ae682451 /net/p5-Net-Patricia
parentd8406966d6bacb3659d136807edaa0e2ee8bfa6c (diff)
downloadports-285996cdec4e777695f67857f0f77879b0614258.tar.gz
ports-285996cdec4e777695f67857f0f77879b0614258.zip
Notes
Diffstat (limited to 'net/p5-Net-Patricia')
-rw-r--r--net/p5-Net-Patricia/Makefile21
-rw-r--r--net/p5-Net-Patricia/pkg-comment1
-rw-r--r--net/p5-Net-Patricia/pkg-descr17
-rw-r--r--net/p5-Net-Patricia/pkg-plist5
4 files changed, 44 insertions, 0 deletions
diff --git a/net/p5-Net-Patricia/Makefile b/net/p5-Net-Patricia/Makefile
new file mode 100644
index 000000000000..5b289a09d76a
--- /dev/null
+++ b/net/p5-Net-Patricia/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Net-Patricia
+# Date created: Di 13 Mär 2001 19:37:25 CET
+# Whom: Andreas Klemm <andreas@klemm.gtn.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Patricia
+PORTVERSION= 1.010
+CATEGORIES= net perl5
+MASTER_SITES= http://net.doit.wisc.edu/~plonka/Net-Patricia/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+PERL_CONFIGURE= YES
+
+MAN3= Net::Patricia.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Patricia/pkg-comment b/net/p5-Net-Patricia/pkg-comment
new file mode 100644
index 000000000000..e96482d5d343
--- /dev/null
+++ b/net/p5-Net-Patricia/pkg-comment
@@ -0,0 +1 @@
+perl module for fast IP address lookups
diff --git a/net/p5-Net-Patricia/pkg-descr b/net/p5-Net-Patricia/pkg-descr
new file mode 100644
index 000000000000..4abdcb46f2c8
--- /dev/null
+++ b/net/p5-Net-Patricia/pkg-descr
@@ -0,0 +1,17 @@
+This module uses a Patricia Trie data structure to quickly perform
+IP address prefix matching for applications such as IP subnet,
+network or routing table lookups. The data structure is based on
+a radix tree using a radix of two, so sometimes you see patricia
+implementations called "radix" as well. The term "Trie" is derived
+from the word "retrieval" but is pronounced like "try". Patricia
+stands for "Practical Algorithm to Retrieve Information Coded as
+Alphanumeric", and was first suggested for routing table lookups
+by Van Jacobsen. Patricia Trie performance characteristics are
+well-known as it has been employed for routing table lookups within
+the BSD kernel since the 4.3 Reno release.
+
+The BSD radix code is thoroughly described in "TCP/IP Illustrated,
+Volume 2" by Wright and Stevens and in the paper ``A Tree-Based
+Packet Routing Table for Berkeley Unix'' by Keith Sklower.
+
+WWW: http://net.doit.wisc.edu/~plonka/Net-Patricia/
diff --git a/net/p5-Net-Patricia/pkg-plist b/net/p5-Net-Patricia/pkg-plist
new file mode 100644
index 000000000000..fda73cd1faa9
--- /dev/null
+++ b/net/p5-Net-Patricia/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Patricia/Patricia.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Patricia/Patricia.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Patricia/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Patricia.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Patricia