aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-SCP-Expect
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-15 10:42:54 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-15 10:42:54 +0000
commit0e95c4b3cf4a478ab1f0630beba8cf3f8746c041 (patch)
tree1cdeed9a384d569ac9cc3f2a055ccbc5818b6307 /net/p5-Net-SCP-Expect
parent6f97e07321e8cfee667ba8d5209bc186ac6e9791 (diff)
downloadports-0e95c4b3cf4a478ab1f0630beba8cf3f8746c041.tar.gz
ports-0e95c4b3cf4a478ab1f0630beba8cf3f8746c041.zip
Notes
Diffstat (limited to 'net/p5-Net-SCP-Expect')
-rw-r--r--net/p5-Net-SCP-Expect/Makefile25
-rw-r--r--net/p5-Net-SCP-Expect/distinfo3
-rw-r--r--net/p5-Net-SCP-Expect/pkg-descr3
-rw-r--r--net/p5-Net-SCP-Expect/pkg-plist7
4 files changed, 38 insertions, 0 deletions
diff --git a/net/p5-Net-SCP-Expect/Makefile b/net/p5-Net-SCP-Expect/Makefile
new file mode 100644
index 000000000000..09d808322d70
--- /dev/null
+++ b/net/p5-Net-SCP-Expect/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-SCP-Expect
+# Date created: 27 Feb 2006
+# Whom: Simun Mikecin <numisemis@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SCP-Expect
+PORTVERSION= 0.12
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= numisemis@yahoo.com
+COMMENT= Perl5 wrapper for scp that allows passwords via Expect
+
+BUILD_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SCP::Expect.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SCP-Expect/distinfo b/net/p5-Net-SCP-Expect/distinfo
new file mode 100644
index 000000000000..1812ff85104a
--- /dev/null
+++ b/net/p5-Net-SCP-Expect/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-SCP-Expect-0.12.tar.gz) = ed57459ab1511bed85479bdcb18cc67a
+SHA256 (Net-SCP-Expect-0.12.tar.gz) = dd715f39ea4011797d747d2575b4933d603ff32f242b3b2cf9ca791cd7bec450
+SIZE (Net-SCP-Expect-0.12.tar.gz) = 160355
diff --git a/net/p5-Net-SCP-Expect/pkg-descr b/net/p5-Net-SCP-Expect/pkg-descr
new file mode 100644
index 000000000000..2f337616e040
--- /dev/null
+++ b/net/p5-Net-SCP-Expect/pkg-descr
@@ -0,0 +1,3 @@
+This module is simply a wrapper around the scp call. The primary difference
+between this module and I<Net::SCP> is that you may send a password
+programmatically, instead of being forced to deal with interactive sessions.
diff --git a/net/p5-Net-SCP-Expect/pkg-plist b/net/p5-Net-SCP-Expect/pkg-plist
new file mode 100644
index 000000000000..6a0a89c81c21
--- /dev/null
+++ b/net/p5-Net-SCP-Expect/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/SCP/Expect.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SCP/Expect/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SCP/Expect
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SCP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/SCP
+@dirrmtry %%SITE_PERL%%/Net