aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-SDP
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2005-06-17 13:11:02 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2005-06-17 13:11:02 +0000
commit2c1e23ea78fa9d6ef92fa27b05e8455e60a15569 (patch)
tree2b73bd8f57ff21f45000f3a2bfc2dce5acaa3c98 /net/p5-Net-SDP
parent5dcd5095927aeb4a6598a0246c8e9733106df339 (diff)
downloadports-2c1e23ea78fa9d6ef92fa27b05e8455e60a15569.tar.gz
ports-2c1e23ea78fa9d6ef92fa27b05e8455e60a15569.zip
Notes
Diffstat (limited to 'net/p5-Net-SDP')
-rw-r--r--net/p5-Net-SDP/Makefile26
-rw-r--r--net/p5-Net-SDP/distinfo2
-rw-r--r--net/p5-Net-SDP/pkg-descr9
-rw-r--r--net/p5-Net-SDP/pkg-plist6
4 files changed, 43 insertions, 0 deletions
diff --git a/net/p5-Net-SDP/Makefile b/net/p5-Net-SDP/Makefile
new file mode 100644
index 000000000000..16421d81b98f
--- /dev/null
+++ b/net/p5-Net-SDP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Net-SDP
+# Date created: 17 June 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SDP
+PORTVERSION= 0.02
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Session Description Protocol (RFC 2327) packet parser/generator
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN1= sdp2rat.1
+MAN3= Net::SDP.3 Net::SDP::Media.3 Net::SDP::Time.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SDP/distinfo b/net/p5-Net-SDP/distinfo
new file mode 100644
index 000000000000..394c66bf69d1
--- /dev/null
+++ b/net/p5-Net-SDP/distinfo
@@ -0,0 +1,2 @@
+MD5 (Net-SDP-0.02.tar.gz) = 175a629f45c52dce04ef088cd3e0becb
+SIZE (Net-SDP-0.02.tar.gz) = 15500
diff --git a/net/p5-Net-SDP/pkg-descr b/net/p5-Net-SDP/pkg-descr
new file mode 100644
index 000000000000..1fb48d41b753
--- /dev/null
+++ b/net/p5-Net-SDP/pkg-descr
@@ -0,0 +1,9 @@
+Net::SDP is an SDP (Session Description Protocol) parser and generator.
+Net::SDP is object oriented and a single instance of Net::SDP represents
+a single SDP session description. There are methods to easily get, set
+and create each of the fields in the session description.
+
+The classes Net::SDP::Time and Net::SDP::Media are automatically
+instantiated for each Time Description (t=) and Media Description (m=).
+
+WWW: http://search.cpan.org/dist/Net-SDP/
diff --git a/net/p5-Net-SDP/pkg-plist b/net/p5-Net-SDP/pkg-plist
new file mode 100644
index 000000000000..5429fa62d48a
--- /dev/null
+++ b/net/p5-Net-SDP/pkg-plist
@@ -0,0 +1,6 @@
+bin/sdp2rat
+%%SITE_PERL%%/Net/SDP.pm
+%%SITE_PERL%%/Net/SDP/Media.pm
+%%SITE_PERL%%/Net/SDP/Time.pm
+@dirrm %%SITE_PERL%%/Net/SDP
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true