aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-SMPP
diff options
context:
space:
mode:
authorJohn Hay <jhay@FreeBSD.org>2002-05-21 05:44:26 +0000
committerJohn Hay <jhay@FreeBSD.org>2002-05-21 05:44:26 +0000
commit95eac86d6f34452f116e95d3a4b7e1caafea4c1f (patch)
treecf7410237085073919e085cc3ad9c69ff0448509 /net/p5-Net-SMPP
parent3cbeb2fd4f05aab0d652cfa9c809b28b3d88a9b3 (diff)
downloadports-95eac86d6f34452f116e95d3a4b7e1caafea4c1f.tar.gz
ports-95eac86d6f34452f116e95d3a4b7e1caafea4c1f.zip
Perl5 module to use the SMPP (Short Message Peer to Peer) protocol.
Notes
Notes: svn path=/head/; revision=59597
Diffstat (limited to 'net/p5-Net-SMPP')
-rw-r--r--net/p5-Net-SMPP/Makefile22
-rw-r--r--net/p5-Net-SMPP/distinfo1
-rw-r--r--net/p5-Net-SMPP/pkg-comment1
-rw-r--r--net/p5-Net-SMPP/pkg-descr4
-rw-r--r--net/p5-Net-SMPP/pkg-plist11
5 files changed, 39 insertions, 0 deletions
diff --git a/net/p5-Net-SMPP/Makefile b/net/p5-Net-SMPP/Makefile
new file mode 100644
index 000000000000..f07da4229a71
--- /dev/null
+++ b/net/p5-Net-SMPP/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: Net-SMPP
+# Date created: 20 May 2002
+# Whom: jhay
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SMPP
+PORTVERSION= 1.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jhay@FreeBSD.org
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::SMPP.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SMPP/distinfo b/net/p5-Net-SMPP/distinfo
new file mode 100644
index 000000000000..a00f75e17c0e
--- /dev/null
+++ b/net/p5-Net-SMPP/distinfo
@@ -0,0 +1 @@
+MD5 (Net-SMPP-1.01.tar.gz) = 32f37e09d1f149733af086cc69d65a00
diff --git a/net/p5-Net-SMPP/pkg-comment b/net/p5-Net-SMPP/pkg-comment
new file mode 100644
index 000000000000..9714e82ee048
--- /dev/null
+++ b/net/p5-Net-SMPP/pkg-comment
@@ -0,0 +1 @@
+Net::SMPP - pure Perl implementation of SMPP 3.4 over TCP
diff --git a/net/p5-Net-SMPP/pkg-descr b/net/p5-Net-SMPP/pkg-descr
new file mode 100644
index 000000000000..ad5e1b07d20f
--- /dev/null
+++ b/net/p5-Net-SMPP/pkg-descr
@@ -0,0 +1,4 @@
+Implements Short Message Peer to Peer protocol, which is frequently used to
+pass short messages between mobile operators implementing short message
+service (SMS). This is applicable to both european GSM and american CDMA/TDMA
+systems.
diff --git a/net/p5-Net-SMPP/pkg-plist b/net/p5-Net-SMPP/pkg-plist
new file mode 100644
index 000000000000..31e26f6e6cad
--- /dev/null
+++ b/net/p5-Net-SMPP/pkg-plist
@@ -0,0 +1,11 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SMPP/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Net/smsc.pl
+lib/perl5/site_perl/%%PERL_VER%%/Net/sendmessage.pl
+lib/perl5/site_perl/%%PERL_VER%%/Net/esme-rec.pl
+lib/perl5/site_perl/%%PERL_VER%%/Net/esme-hammer.pl
+lib/perl5/site_perl/%%PERL_VER%%/Net/SMPP.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/esme.pl
+lib/perl5/site_perl/%%PERL_VER%%/Net/bind-hammer.pl
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/SMPP
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true