aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-SMS-Clickatell
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-10 04:50:56 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-12-10 04:50:56 +0000
commit584292a25ad2f0eb3a79ce50c847bb83a699ec25 (patch)
tree25449b27f45e0f1a5e342047fd2ec7f804e20795 /net/p5-Net-SMS-Clickatell
parent28706a2e2ac2b1690cc7e12bfb29f68ad0ecec39 (diff)
downloadports-584292a25ad2f0eb3a79ce50c847bb83a699ec25.tar.gz
ports-584292a25ad2f0eb3a79ce50c847bb83a699ec25.zip
Notes
Diffstat (limited to 'net/p5-Net-SMS-Clickatell')
-rw-r--r--net/p5-Net-SMS-Clickatell/Makefile24
-rw-r--r--net/p5-Net-SMS-Clickatell/distinfo2
-rw-r--r--net/p5-Net-SMS-Clickatell/files/patch-lib-Net-SMS-Clickatell.pm20
-rw-r--r--net/p5-Net-SMS-Clickatell/pkg-descr6
-rw-r--r--net/p5-Net-SMS-Clickatell/pkg-plist7
5 files changed, 59 insertions, 0 deletions
diff --git a/net/p5-Net-SMS-Clickatell/Makefile b/net/p5-Net-SMS-Clickatell/Makefile
new file mode 100644
index 000000000000..e5451109dec5
--- /dev/null
+++ b/net/p5-Net-SMS-Clickatell/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Net-SMS-Clickatell
+# Date created: 2010-12-01
+# Whom: John Bayly <freebsd.ports@tipstrade.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SMS-Clickatell
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= freebsd.ports@tipstrade.net
+COMMENT= Access to Clickatell SMS messaging service
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SMS::Clickatell.3
+
+post-patch:
+ ${FIND} ${WRKSRC} -name "*.orig" -delete
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SMS-Clickatell/distinfo b/net/p5-Net-SMS-Clickatell/distinfo
new file mode 100644
index 000000000000..93555568ebec
--- /dev/null
+++ b/net/p5-Net-SMS-Clickatell/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-SMS-Clickatell-0.05.tar.gz) = 50475cd5b40e0322b72fe5ff5259ecf110bd8a11243549897383f3e14cc9f524
+SIZE (Net-SMS-Clickatell-0.05.tar.gz) = 3924
diff --git a/net/p5-Net-SMS-Clickatell/files/patch-lib-Net-SMS-Clickatell.pm b/net/p5-Net-SMS-Clickatell/files/patch-lib-Net-SMS-Clickatell.pm
new file mode 100644
index 000000000000..a53bdd6d9311
--- /dev/null
+++ b/net/p5-Net-SMS-Clickatell/files/patch-lib-Net-SMS-Clickatell.pm
@@ -0,0 +1,20 @@
+--- lib/Net/SMS/Clickatell.pm.orig 2004-11-30 16:20:13.000000000 +0000
++++ lib/Net/SMS/Clickatell.pm 2010-12-02 00:57:10.000000000 +0000
+@@ -89,7 +89,7 @@
+ if(!exists $args{BaseURL}) {
+ # BaseURL argument wasn't passed. Set it to default.
+ # Check if we have to use SSL.
+- if(exists $args{UseSSL}) {
++ if($args{UseSSL}) {
+ $args{BaseURL} = 'https://api.clickatell.com';
+ } else {
+ $args{BaseURL} = 'http://api.clickatell.com';
+@@ -97,7 +97,7 @@
+ } else {
+ # Set BaseURL property value.
+ # Check if we have to use SSL.
+- if(exists $args{UseSSL}) {
++ if($args{UseSSL}) {
+ $args{BaseURL} = 'https://'.$args{BaseURL};
+ } else {
+ $args{BaseURL} = 'http://'.$args{BaseURL};
diff --git a/net/p5-Net-SMS-Clickatell/pkg-descr b/net/p5-Net-SMS-Clickatell/pkg-descr
new file mode 100644
index 000000000000..1c5cb8225b55
--- /dev/null
+++ b/net/p5-Net-SMS-Clickatell/pkg-descr
@@ -0,0 +1,6 @@
+Net::SMS::Clickatell - Access to Clickatell SMS messaging service.
+Clickatell is a commercial service that allows its users to send SMS messages
+to anyone in the world. This service supports many ways to send messages, for
+example HTTP, SMTP and SMPP, among others.
+
+WWW: http://search.cpan.org/dist/Net-SMS-Clickatell-0.05/
diff --git a/net/p5-Net-SMS-Clickatell/pkg-plist b/net/p5-Net-SMS-Clickatell/pkg-plist
new file mode 100644
index 000000000000..7c12f63e377a
--- /dev/null
+++ b/net/p5-Net-SMS-Clickatell/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/SMS/Clickatell.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMS/Clickatell/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMS/Clickatell
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SMS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/SMS
+@dirrmtry %%SITE_PERL%%/Net