aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-SSH-Expect/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-06-30 10:39:30 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-06-30 10:39:30 +0000
commit58023de076a67db7f0de12879e763aa352286c77 (patch)
treea9c1e58db573640125fd975b60687e21a86e11fb /net/p5-Net-SSH-Expect/Makefile
parentd092caca1782cb368c2f9f75d39438533f41da3b (diff)
downloadports-58023de076a67db7f0de12879e763aa352286c77.tar.gz
ports-58023de076a67db7f0de12879e763aa352286c77.zip
Notes
Diffstat (limited to 'net/p5-Net-SSH-Expect/Makefile')
-rw-r--r--net/p5-Net-SSH-Expect/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/p5-Net-SSH-Expect/Makefile b/net/p5-Net-SSH-Expect/Makefile
new file mode 100644
index 000000000000..e41ee50fb4c9
--- /dev/null
+++ b/net/p5-Net-SSH-Expect/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Net-SSH-Expect
+# Date created: 2007-06-30
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SSH-Expect
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= SSH wrapper to execute remote commands
+
+RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SSH::Expect.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 due to dependency. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>