aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-SSH-Perl/Makefile
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2014-04-09 16:28:21 +0000
committerFrederic Culot <culot@FreeBSD.org>2014-04-09 16:28:21 +0000
commit96b64976833a337109f790da739b017e2026c084 (patch)
tree43919d9420af2f76e6ff5d3c8e2e8ef85aef6a44 /net/p5-Net-SSH-Perl/Makefile
parente387fda4873e79f584422dfead5aca6bae6e80d4 (diff)
downloadports-96b64976833a337109f790da739b017e2026c084.tar.gz
ports-96b64976833a337109f790da739b017e2026c084.zip
Notes
Diffstat (limited to 'net/p5-Net-SSH-Perl/Makefile')
-rw-r--r--net/p5-Net-SSH-Perl/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/net/p5-Net-SSH-Perl/Makefile b/net/p5-Net-SSH-Perl/Makefile
index 2d169aca791c..e53402f76af8 100644
--- a/net/p5-Net-SSH-Perl/Makefile
+++ b/net/p5-Net-SSH-Perl/Makefile
@@ -2,24 +2,29 @@
# $FreeBSD$
PORTNAME= Net-SSH-Perl
-PORTVERSION= 1.36
-CATEGORIES= net perl5
+PORTVERSION= 1.37
+CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
-COMMENT= Perl5 module implements both the SSH1 and SSH2 protocols
+COMMENT= Perl5 module implementing both the SSH1 and SSH2 protocols
-BUILD_DEPENDS= p5-String-CRC32>=0:${PORTSDIR}/devel/p5-String-CRC32 \
- p5-Math-GMP>=0:${PORTSDIR}/math/p5-Math-GMP \
- p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
- p5-Crypt-DSA>=0:${PORTSDIR}/security/p5-Crypt-DSA \
- p5-Crypt-DH>=0:${PORTSDIR}/security/p5-Crypt-DH \
- p5-Math-Pari>=0:${PORTSDIR}/math/p5-Math-Pari \
- p5-Convert-PEM>=0:${PORTSDIR}/converters/p5-Convert-PEM \
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Convert-PEM>=0.05:${PORTSDIR}/converters/p5-Convert-PEM \
+ p5-Crypt-DES>0:${PORTSDIR}/security/p5-Crypt-DES \
+ p5-Crypt-DH>=0.01:${PORTSDIR}/security/p5-Crypt-DH \
+ p5-Crypt-DSA>=0.11:${PORTSDIR}/security/p5-Crypt-DSA \
p5-Crypt-IDEA>=0:${PORTSDIR}/security/p5-Crypt-IDEA \
+ p5-Crypt-RSA>=0:${PORTSDIR}/security/p5-Crypt-RSA \
p5-Digest-BubbleBabble>=0:${PORTSDIR}/security/p5-Digest-BubbleBabble \
- p5-Crypt-RSA>=0:${PORTSDIR}/security/p5-Crypt-RSA
+ p5-Digest-HMAC>=0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-Digest-SHA1>=2.10:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Math-GMP>=1.04:${PORTSDIR}/math/p5-Math-GMP \
+ p5-Math-Pari>=2.001804:${PORTSDIR}/math/p5-Math-Pari \
+ p5-String-CRC32>=1.2:${PORTSDIR}/devel/p5-String-CRC32
RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFIGURE_ENV+= PERL_MM_USE_DEFAULT="1"