aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Server
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-01-26 10:34:42 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-01-26 10:34:42 +0000
commit29341474465cdbddd3f39b63bd7825075a3dfca5 (patch)
tree39d3cd2d2fc17d1e5f1849e13fabb0e16cb1a0d7 /net/p5-Net-Server
parent1a7cb7e414c6600a2c3d30e8d2d2baaa50503ddb (diff)
downloadports-29341474465cdbddd3f39b63bd7825075a3dfca5.tar.gz
ports-29341474465cdbddd3f39b63bd7825075a3dfca5.zip
Notes
Diffstat (limited to 'net/p5-Net-Server')
-rw-r--r--net/p5-Net-Server/Makefile2
-rw-r--r--net/p5-Net-Server/files/patch-lib_Net_Server.pm20
2 files changed, 21 insertions, 1 deletions
diff --git a/net/p5-Net-Server/Makefile b/net/p5-Net-Server/Makefile
index 56a6f7ec210c..53dc3b0d0e8c 100644
--- a/net/p5-Net-Server/Makefile
+++ b/net/p5-Net-Server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Net-Server
PORTVERSION= 0.90
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= http://www.seamons.com/net_server/ \
${MASTER_SITE_PERL_CPAN}
diff --git a/net/p5-Net-Server/files/patch-lib_Net_Server.pm b/net/p5-Net-Server/files/patch-lib_Net_Server.pm
new file mode 100644
index 000000000000..a115f0ceab5b
--- /dev/null
+++ b/net/p5-Net-Server/files/patch-lib_Net_Server.pm
@@ -0,0 +1,20 @@
+--- lib/Net/Server.pm Mon Dec 5 22:13:04 2005
++++ lib/Net/Server.pm Wed Jan 25 08:18:25 2006
+@@ -133,6 +133,7 @@
+ ### see if we can find the full command line
+ if (open _CMDLINE, "/proc/$$/cmdline") { # unix specific
+ my $line = do { local $/ = undef; <_CMDLINE> };
++ ($line) = $line =~ /^(.*)$/; # untaint
+ close _CMDLINE;
+ if ($line) {
+ return [split /\0/, $line];
+@@ -140,7 +141,8 @@
+ }
+
+ my $script = $0;
+- $script = $ENV{'PWD'} .'/'. $script if $script =~ m|^\.+/| && $ENV{'PWD'}; # add absolute to relative
++ $script = $ENV{'PWD'} .'/'. $script if $script !~ m|^/| && $ENV{'PWD'}; # add absolute to relative
++ ($script) = $script =~ /^(.*)$/; # untaint
+ return [ $script, @ARGV ]
+ }
+