aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-TiVo/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-10 21:11:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-10 21:11:48 +0000
commit60f09f5d864d437f073f52962a517a6b2579291e (patch)
tree37b58d4a32e751ad5ab14c381dabc8018424616c /net/p5-Net-TiVo/Makefile
parent18b0c8029105207d680de6882da72bdbf3e93115 (diff)
downloadports-60f09f5d864d437f073f52962a517a6b2579291e.tar.gz
ports-60f09f5d864d437f073f52962a517a6b2579291e.zip
Notes
Diffstat (limited to 'net/p5-Net-TiVo/Makefile')
-rw-r--r--net/p5-Net-TiVo/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/p5-Net-TiVo/Makefile b/net/p5-Net-TiVo/Makefile
new file mode 100644
index 000000000000..75a0df9ff6f0
--- /dev/null
+++ b/net/p5-Net-TiVo/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Net-TiVo
+# Date created: Jan 10 2006
+# Whom: Christopher Boumenot <boumenot@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-TiVo
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= boumenot@gmail.com
+COMMENT= Framework for accessing TiVo using XML/HTTP
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::TiVo.3 \
+ Net::TiVo::Show.3 \
+ Net::TiVo::Folder.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires perl 5.8.x or later. Install lang/perl58 then try again
+.endif
+
+.include <bsd.port.post.mk>