aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Traceroute-PurePerl
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-04-08 06:16:39 +0000
committerWen Heping <wen@FreeBSD.org>2010-04-08 06:16:39 +0000
commitf3c68e0e301ea43e31e5df449161d500693dd309 (patch)
tree4f19f4f020c4458330d6f4cbb454cff066626f12 /net/p5-Net-Traceroute-PurePerl
parentcfa207ec25181cb6c8ad10915b37094ed853cb0d (diff)
downloadports-f3c68e0e301ea43e31e5df449161d500693dd309.tar.gz
ports-f3c68e0e301ea43e31e5df449161d500693dd309.zip
Notes
Diffstat (limited to 'net/p5-Net-Traceroute-PurePerl')
-rw-r--r--net/p5-Net-Traceroute-PurePerl/Makefile24
-rw-r--r--net/p5-Net-Traceroute-PurePerl/distinfo3
-rw-r--r--net/p5-Net-Traceroute-PurePerl/pkg-descr8
-rw-r--r--net/p5-Net-Traceroute-PurePerl/pkg-plist7
4 files changed, 42 insertions, 0 deletions
diff --git a/net/p5-Net-Traceroute-PurePerl/Makefile b/net/p5-Net-Traceroute-PurePerl/Makefile
new file mode 100644
index 000000000000..9c4e7e39bbe8
--- /dev/null
+++ b/net/p5-Net-Traceroute-PurePerl/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Net-Traceroute-PurePerl
+# Date created: April 01 2010
+# Whom: jupengfei <jupengfei@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Traceroute-PurePerl
+PORTVERSION= 0.10
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jupengfei@gmail.com
+COMMENT= Traceroute(1) functionality in perl via raw sockets
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Traceroute.pm:${PORTSDIR}/net/p5-Net-Traceroute
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= Net::Traceroute::PurePerl.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Traceroute-PurePerl/distinfo b/net/p5-Net-Traceroute-PurePerl/distinfo
new file mode 100644
index 000000000000..f2374f55989b
--- /dev/null
+++ b/net/p5-Net-Traceroute-PurePerl/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Traceroute-PurePerl-0.10.tar.gz) = acaabd4207532a50705ba514af2c905f
+SHA256 (Net-Traceroute-PurePerl-0.10.tar.gz) = d1e31da0b07b17ed1ee7a0ff191da71fcf144fcd11651e017cfb8f4f485df5dd
+SIZE (Net-Traceroute-PurePerl-0.10.tar.gz) = 20410
diff --git a/net/p5-Net-Traceroute-PurePerl/pkg-descr b/net/p5-Net-Traceroute-PurePerl/pkg-descr
new file mode 100644
index 000000000000..4fbebb743968
--- /dev/null
+++ b/net/p5-Net-Traceroute-PurePerl/pkg-descr
@@ -0,0 +1,8 @@
+Net::Traceroute::PurePerl implements traceroute(1) functionality for
+perl5. It allows you to trace the path IP packets take to a destination.
+It is implemented by using raw sockets to act just like the regular
+traceroute.
+
+You must also be root to use the raw sockets.
+
+WWW: http://search.cpan.org/dist/Net-Traceroute-PurePerl
diff --git a/net/p5-Net-Traceroute-PurePerl/pkg-plist b/net/p5-Net-Traceroute-PurePerl/pkg-plist
new file mode 100644
index 000000000000..74b9230184fa
--- /dev/null
+++ b/net/p5-Net-Traceroute-PurePerl/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/Traceroute/PurePerl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Traceroute/PurePerl/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Traceroute/PurePerl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Traceroute
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Traceroute
+@dirrmtry %%SITE_PERL%%/Net