aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Twitter
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-08-03 08:48:54 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-08-03 08:48:54 +0000
commita9f0e910ddf8d7326fc3873f7968d2cd767c9eba (patch)
treebccb010e297e45ab1abdc9f0dfbbac8f7462faee /net/p5-Net-Twitter
parent3f252dc4cded880ab631da6ea33007524ee26c8e (diff)
downloadports-a9f0e910ddf8d7326fc3873f7968d2cd767c9eba.tar.gz
ports-a9f0e910ddf8d7326fc3873f7968d2cd767c9eba.zip
Notes
Diffstat (limited to 'net/p5-Net-Twitter')
-rw-r--r--net/p5-Net-Twitter/Makefile25
-rw-r--r--net/p5-Net-Twitter/distinfo3
-rw-r--r--net/p5-Net-Twitter/pkg-descr8
-rw-r--r--net/p5-Net-Twitter/pkg-plist5
4 files changed, 41 insertions, 0 deletions
diff --git a/net/p5-Net-Twitter/Makefile b/net/p5-Net-Twitter/Makefile
new file mode 100644
index 000000000000..e47ba8f24334
--- /dev/null
+++ b/net/p5-Net-Twitter/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Net-Twitter
+# Date created: 2007-08-03
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Twitter
+PORTVERSION= 1.05
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl interface to twitter.com
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/JSON/Any.pm:${PORTSDIR}/converters/p5-JSON-Any
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Twitter.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Twitter/distinfo b/net/p5-Net-Twitter/distinfo
new file mode 100644
index 000000000000..15e3b24eda3c
--- /dev/null
+++ b/net/p5-Net-Twitter/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Twitter-1.05.tar.gz) = 47c8d28f22c2698b6e00b45db3487b72
+SHA256 (Net-Twitter-1.05.tar.gz) = e7b02bd30a465b3563e8409f23d77737c038fbceda5dc0226cee50388a075a44
+SIZE (Net-Twitter-1.05.tar.gz) = 7090
diff --git a/net/p5-Net-Twitter/pkg-descr b/net/p5-Net-Twitter/pkg-descr
new file mode 100644
index 000000000000..defe91fd8066
--- /dev/null
+++ b/net/p5-Net-Twitter/pkg-descr
@@ -0,0 +1,8 @@
+twitter.com provides a web 2.0 type of ubiquitous presence.
+This module allows you to set your status, as well as the statuses of
+your friends.
+
+You can view the latest status of Net::Twitter on it's own twitter
+timeline at http://twitter.com/net_twitter
+
+WWW: http://search.cpan.org/dist/Net-Twitter/
diff --git a/net/p5-Net-Twitter/pkg-plist b/net/p5-Net-Twitter/pkg-plist
new file mode 100644
index 000000000000..b0c9c5297dac
--- /dev/null
+++ b/net/p5-Net-Twitter/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Twitter/.packlist
+%%SITE_PERL%%/Net/Twitter.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Twitter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net