aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Twitter
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-09-21 16:08:11 +0000
commit17e550ca2fd180b150f6645ced5f3bb45bc32292 (patch)
treee856fa025c5b15bbef21f621e347c51780662a47 /net/p5-Net-Twitter
parentb4599e3d63c3a94b17026b18d1f8ac27faac53fc (diff)
downloadports-17e550ca2fd180b150f6645ced5f3bb45bc32292.tar.gz
ports-17e550ca2fd180b150f6645ced5f3bb45bc32292.zip
Notes
Diffstat (limited to 'net/p5-Net-Twitter')
-rw-r--r--net/p5-Net-Twitter/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/net/p5-Net-Twitter/Makefile b/net/p5-Net-Twitter/Makefile
index 7d9e29f56f67..24abdcf96780 100644
--- a/net/p5-Net-Twitter/Makefile
+++ b/net/p5-Net-Twitter/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-Twitter
PORTVERSION= 3.13007
+PORTREVISION= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= clsung@FreeBSD.org
COMMENT= Perl interface to twitter.com
-BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA.pm:${PORTSDIR}/security/p5-Digest-SHA \
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/Data/Visitor/Callback.pm:${PORTSDIR}/devel/p5-Data-Visitor \
${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
${SITE_PERL}/MooseX/AttributeHelpers.pm:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
@@ -24,7 +24,7 @@ BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/namespace/autoclean.pm:${PORTSDIR}/devel/p5-namespace-autoclean \
${SITE_PERL}/Net/OAuth/Simple.pm:${PORTSDIR}/net/p5-Net-OAuth-Simple \
${SITE_PERL}/JSON/Any.pm:${PORTSDIR}/converters/p5-JSON-Any
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -43,4 +43,10 @@ MAN3= Net::Twitter.3 Net::Twitter::Search.3 Net::Identica.3 \
Net::Twitter::Role::SimulateCursors.3 \
Net::Twitter::Role::WrapError.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+RUN_DEPENDS+= p5-Digest-SHA>=5.47:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>