aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-01-05 18:38:49 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-01-05 18:38:49 +0000
commit4a65a72f042a7c043981d6ac86b4b0f6623b9759 (patch)
tree0de87a4ee5b6d943be949d0f477bd49c29d07bbc /net/p5-Net/Makefile
parente63345d8318848b2c96230f61a44a73ac0184c27 (diff)
downloadports-4a65a72f042a7c043981d6ac86b4b0f6623b9759.tar.gz
ports-4a65a72f042a7c043981d6ac86b4b0f6623b9759.zip
Notes
Diffstat (limited to 'net/p5-Net/Makefile')
-rw-r--r--net/p5-Net/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/net/p5-Net/Makefile b/net/p5-Net/Makefile
index f559a0adbcc9..9c847e65e687 100644
--- a/net/p5-Net/Makefile
+++ b/net/p5-Net/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Net
-PORTVERSION= 1.30
+PORTVERSION= 3.04
PORTEPOCH= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
@@ -19,15 +19,18 @@ OPTIONS_DEFINE= IPV6 SASL SSL
OPTIONS_DEFAULT=SASL
SASL_DESC= SASL auth for POP3 and SMTP support
+BUILD_DEPENDS= p5-Socket>=2.016:${PORTSDIR}/net/p5-Socket
+RUN_DEPENDS= p5-Socket>=2.016:${PORTSDIR}/net/p5-Socket
+
SASL_BUILD_DEPENDS= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
SASL_RUN_DEPENDS= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
-SSL_BUILD_DEPENDS= p5-IO-Socket-SSL>=1.994:${PORTSDIR}/security/p5-IO-Socket-SSL
-SSL_RUN_DEPENDS= p5-IO-Socket-SSL>=1.994:${PORTSDIR}/security/p5-IO-Socket-SSL
-
-PORTSCOUT= skipv:1.0901
+SSL_BUILD_DEPENDS= p5-IO-Socket-SSL>=2.007:${PORTSDIR}/security/p5-IO-Socket-SSL
+SSL_RUN_DEPENDS= p5-IO-Socket-SSL>=2.007:${PORTSDIR}/security/p5-IO-Socket-SSL
USES= perl5
USE_PERL5= configure
+CONFIGURE_ENV= PERL5_CPAN_IS_RUNNING=1
+NO_ARCH= yes
.include <bsd.port.pre.mk>