aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-10-25 16:57:16 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-10-25 16:57:16 +0000
commitbd0fc2d8ea7db92f4ed96ed0b09535dd8cea0284 (patch)
treefad9d1bd5dee8d115701608542e52b7c086c8c5a /net/p5-Net/Makefile
parent031be3bf022a7aa34c42a3f5011ae91157b94e6f (diff)
Notes
Diffstat (limited to 'net/p5-Net/Makefile')
-rw-r--r--net/p5-Net/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/net/p5-Net/Makefile b/net/p5-Net/Makefile
index fb5f38f8cdc2..91f538a2a307 100644
--- a/net/p5-Net/Makefile
+++ b/net/p5-Net/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net
PORTVERSION= 1.22
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
@@ -16,11 +17,9 @@ DISTNAME= libnet-${PORTVERSION}
MAINTAINER= mat@FreeBSD.org
COMMENT= Perl5 modules to access and use network protocols
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL
+RUN_DEPENDS= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
PERL_CONFIGURE= yes
-CONFIGURE_ARGS= < /dev/null
MAN3= Net::Cmd.3 \
Net::Config.3 \
@@ -33,4 +32,11 @@ MAN3= Net::Cmd.3 \
Net::Time.3 \
Net::libnetFAQ.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>