aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2003-08-20 15:49:36 +0000
committerMathieu Arnold <mat@FreeBSD.org>2003-08-20 15:49:36 +0000
commit7ad8c34afe9f07d235b037ecb8cba1519b3af167 (patch)
tree7e65bcfc71c3bed14a55b687830a88237ab7a057 /net/p5-Net
parentf2fbc2ba1c641ce21d5e8c1c57850dc62b636883 (diff)
downloadports-7ad8c34afe9f07d235b037ecb8cba1519b3af167.tar.gz
ports-7ad8c34afe9f07d235b037ecb8cba1519b3af167.zip
Update to 1.16
replace the Configure patch with a CONFIGURE_ARGS patch Makefile.PL so that *all* man pages are generated even for perl < 5.8.0 grab maintainership Approved by: demon (mentor)
Notes
Notes: svn path=/head/; revision=87387
Diffstat (limited to 'net/p5-Net')
-rw-r--r--net/p5-Net/Makefile11
-rw-r--r--net/p5-Net/distinfo2
-rw-r--r--net/p5-Net/files/patch-Makefile.PL21
-rw-r--r--net/p5-Net/files/patch-aa355
-rw-r--r--net/p5-Net/pkg-plist40
5 files changed, 48 insertions, 381 deletions
diff --git a/net/p5-Net/Makefile b/net/p5-Net/Makefile
index ec0b4cda9325..eab7ce6149e8 100644
--- a/net/p5-Net/Makefile
+++ b/net/p5-Net/Makefile
@@ -6,23 +6,24 @@
#
PORTNAME= p5-Net
-PORTVERSION= 1.12
+PORTVERSION= 1.16
PORTEPOCH= 1
CATEGORIES= net perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Net
DISTNAME= libnet-${PORTVERSION}
-MAINTAINER= demon@FreeBSD.org
+MAINTAINER= mat@FreeBSD.org
COMMENT= Perl5 modules to access and use network protocols
-RUN_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL \
- ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS= ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL \
+ ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
PERL_CONFIGURE= yes
+CONFIGURE_ARGS= INSTALLDIRS=site < /dev/null
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::Cmd.3 \
+ Net::Config.3 \
Net::Domain.3 \
Net::FTP.3 \
Net::NNTP.3 \
diff --git a/net/p5-Net/distinfo b/net/p5-Net/distinfo
index c5d3d1651d25..6d2bf8919c39 100644
--- a/net/p5-Net/distinfo
+++ b/net/p5-Net/distinfo
@@ -1 +1 @@
-MD5 (libnet-1.12.tar.gz) = c47ae3028470c6e4cb5903aef729a33e
+MD5 (libnet-1.16.tar.gz) = 79dbf57a7bcc0cef70209f714dd2cb4c
diff --git a/net/p5-Net/files/patch-Makefile.PL b/net/p5-Net/files/patch-Makefile.PL
new file mode 100644
index 000000000000..aaecf22d3378
--- /dev/null
+++ b/net/p5-Net/files/patch-Makefile.PL
@@ -0,0 +1,21 @@
+--- Makefile.PL Wed Aug 20 17:07:25 2003
++++ Makefile.PL~ Wed Aug 20 17:07:16 2003
+@@ -98,6 +98,18 @@
+ Socket => 1.3,
+ IO::Socket => 1.05
+ },
++ 'MAN3PODS' => {
++ 'Net/Cmd.pm' => '$(INST_MAN3DIR)/Net::Cmd.$(MAN3EXT)',
++ 'Net/Config.pm' => '$(INST_MAN3DIR)/Net::Config.$(MAN3EXT)',
++ 'Net/Domain.pm' => '$(INST_MAN3DIR)/Net::Domain.$(MAN3EXT)',
++ 'Net/FTP.pm' => '$(INST_MAN3DIR)/Net::FTP.$(MAN3EXT)',
++ 'Net/NNTP.pm' => '$(INST_MAN3DIR)/Net::NNTP.$(MAN3EXT)',
++ 'Net/Netrc.pm' => '$(INST_MAN3DIR)/Net::Netrc.$(MAN3EXT)',
++ 'Net/POP3.pm' => '$(INST_MAN3DIR)/Net::POP3.$(MAN3EXT)',
++ 'Net/SMTP.pm' => '$(INST_MAN3DIR)/Net::SMTP.$(MAN3EXT)',
++ 'Net/Time.pm' => '$(INST_MAN3DIR)/Net::Time.$(MAN3EXT)',
++ 'Net/libnetFAQ.pod' => '$(INST_MAN3DIR)/Net::libnetFAQ.$(MAN3EXT)',
++ },
+ @ppd,
+ );
+
diff --git a/net/p5-Net/files/patch-aa b/net/p5-Net/files/patch-aa
deleted file mode 100644
index 09254573ba30..000000000000
--- a/net/p5-Net/files/patch-aa
+++ /dev/null
@@ -1,355 +0,0 @@
---- Configure.orig Tue Jan 18 00:44:18 2000
-+++ Configure Sun Apr 23 05:00:59 2000
-@@ -1,4 +1,4 @@
--#!/usr/local/bin/perl
-+#!/usr/bin/perl
- #
- # $Id: Configure,v 1.8 1997/03/04 09:22:32 gbarr Exp $
-
-@@ -258,18 +258,19 @@
-
- #---------------------------------------------------------------------------
-
--if($have_old && !$opt_d)
-- {
-- $msg = <<EDQ;
--
--Ah, I see you already have installed libnet before.
--
--Do you want to modify/update your configuration (y|n) ?
--EDQ
--
-- $opt_d = 1
-- unless get_bool($msg,0);
-- }
-+#if($have_old && !$opt_d)
-+# {
-+# $msg = <<EDQ;
-+#
-+#Ah, I see you already have installed libnet before.
-+#
-+#Do you want to modify/update your configuration (y|n) ?
-+#EDQ
-+#
-+# $opt_d = 1
-+# unless get_bool($msg,0);
-+# }
-+$opt_d = 0;
-
- #---------------------------------------------------------------------------
-
-@@ -286,7 +287,8 @@
- Do you want me to perform hostname lookups (y|n) ?
- EDQ
-
--$cfg{'test_exist'} = get_bool($msg, $oldcfg{'test_exist'});
-+#$cfg{'test_exist'} = get_bool($msg, $oldcfg{'test_exist'});
-+$cfg{'test_exist'} = 0;
-
- print <<EDQ unless $cfg{'test_exist'};
-
-@@ -301,139 +303,144 @@
-
- #---------------------------------------------------------------------------
-
--print <<EDQ;
--
--The following questions all require a list of host names, separated
--with spaces. If you do not have a host available for any of the
--services, then enter a single space, followed by <CR>. To accept the
--default, hit <CR>
--
--EDQ
-+#print <<EDQ;
-+#
-+#The following questions all require a list of host names, separated
-+#with spaces. If you do not have a host available for any of the
-+#services, then enter a single space, followed by <CR>. To accept the
-+#default, hit <CR>
-+#
-+#EDQ
-
- $msg = 'Enter a list of available NNTP hosts :';
-
--$def = $oldcfg{'nntp_hosts'} ||
-- [ default_hostname($ENV{NNTPSERVER},$ENV{NEWSHOST},'news') ];
-+#$def = $oldcfg{'nntp_hosts'} ||
-+# [ default_hostname($ENV{NNTPSERVER},$ENV{NEWSHOST},'news') ];
-
--$cfg{'nntp_hosts'} = get_host_list($msg,$def);
-+#$cfg{'nntp_hosts'} = get_host_list($msg,$def);
-+$cfg{'nntp_hosts'} = [default_hostname($ENV{NNTPSERVER}, $ENV{NEWSHOST}, 'news') ];
-
- #---------------------------------------------------------------------------
-
- $msg = 'Enter a list of available SMTP hosts :';
-
--$def = $oldcfg{'smtp_hosts'} ||
-- [ default_hostname(split(/:/,$ENV{SMTPHOSTS} || ""), 'mailhost') ];
-+#$def = $oldcfg{'smtp_hosts'} ||
-+# [ default_hostname(split(/:/,$ENV{SMTPHOSTS} || ""), 'mailhost') ];
-
--$cfg{'smtp_hosts'} = get_host_list($msg,$def);
-+#$cfg{'smtp_hosts'} = get_host_list($msg,$def);
-+$cfg{'smtp_hosts'} = [ default_hostname(split(/:/,$ENV{SMTPHOSTS} || ""), 'mailhost') ];
-
- #---------------------------------------------------------------------------
-
- $msg = 'Enter a list of available POP3 hosts :';
-
--$def = $oldcfg{'pop3_hosts'} || [];
-+#$def = $oldcfg{'pop3_hosts'} || [];
-
--$cfg{'pop3_hosts'} = get_host_list($msg,$def);
-+#$cfg{'pop3_hosts'} = get_host_list($msg,$def);
-+$cfg{'pop3_hosts'} = [];
-
- #---------------------------------------------------------------------------
-
- $msg = 'Enter a list of available SNPP hosts :';
-
--$def = $oldcfg{'snpp_hosts'} || [];
-+#$def = $oldcfg{'snpp_hosts'} || [];
-
--$cfg{'snpp_hosts'} = get_host_list($msg,$def);
-+#$cfg{'snpp_hosts'} = get_host_list($msg,$def);
-+$cfg{'snpp_hosts'} = [];
-
- #---------------------------------------------------------------------------
-
- $msg = 'Enter a list of available PH Hosts :' ;
-
--$def = $oldcfg{'ph_hosts'} ||
-- [ default_hostname('dirserv') ];
-+#$def = $oldcfg{'ph_hosts'} ||
-+# [ default_hostname('dirserv') ];
-
--$cfg{'ph_hosts'} = get_host_list($msg,$def);
-+#$cfg{'ph_hosts'} = get_host_list($msg,$def);
-+$cfg{'ph_hosts'} = [ default_hostname('dirserv') ];
-
- #---------------------------------------------------------------------------
-
- $msg = 'Enter a list of available TIME Hosts :' ;
-
--$def = $oldcfg{'time_hosts'} || [];
-+#$def = $oldcfg{'time_hosts'} || [];
-
--$cfg{'time_hosts'} = get_host_list($msg,$def);
-+#$cfg{'time_hosts'} = get_host_list($msg,$def);
-+$cfg{'time_hosts'} = [];
-
- #---------------------------------------------------------------------------
-
- $msg = 'Enter a list of available DAYTIME Hosts :' ;
-
--$def = $oldcfg{'daytime_hosts'} || $oldcfg{'time_hosts'};
-+#$def = $oldcfg{'daytime_hosts'} || $oldcfg{'time_hosts'};
-
--$cfg{'daytime_hosts'} = get_host_list($msg,$def);
-+#$cfg{'daytime_hosts'} = get_host_list($msg,$def);
-+$cfg{'daytime_hosts'} = [];
-
- #---------------------------------------------------------------------------
-
--$msg = <<EDQ;
--
--Do you have a firewall/ftp proxy between your machine and the internet
--
--If you use a SOCKS firewall answer no
--
--(y|n) ?
--EDQ
--
--if(get_bool($msg,0)) {
--
-- $msg = <<'EDQ';
--What series of FTP commands do you need to send to your
--firewall to connect to an external host.
--
--user/pass => external user & password
--fwuser/fwpass => firewall user & password
--
--0) None
--1) -----------------------
-- USER user@remote.host
-- PASS pass
--2) -----------------------
-- USER fwuser
-- PASS fwpass
-- USER user@remote.host
-- PASS pass
--3) -----------------------
-- USER fwuser
-- PASS fwpass
-- SITE remote.site
-- USER user
-- PASS pass
--4) -----------------------
-- USER fwuser
-- PASS fwpass
-- OPEN remote.site
-- USER user
-- PASS pass
--5) -----------------------
-- USER user@fwuser@remote.site
-- PASS pass@fwpass
--6) -----------------------
-- USER fwuser@remote.site
-- PASS fwpass
-- USER user
-- PASS pass
--7) -----------------------
-- USER user@remote.host
-- PASS pass
-- AUTH fwuser
-- RESP fwpass
--
--Choice:
--EDQ
-- $def = exists $oldcfg{'ftp_firewall_type'} ? $oldcfg{'ftp_firewall_type'} : 1;
-- $ans = Prompt($msg,$def);
-- $cfg{'ftp_firewall_type'} = 0+$ans;
-- $def = $oldcfg{'ftp_firewall'} || $ENV{FTP_FIREWALL};
-+#$msg = <<EDQ;
-+#
-+#Do you have a firewall/ftp proxy between your machine and the internet
-+#
-+#If you use a SOCKS firewall answer no
-+#
-+#(y|n) ?
-+#EDQ
-+#
-+#if(get_bool($msg,0)) {
-+#
-+# $msg = <<'EDQ';
-+#What series of FTP commands do you need to send to your
-+#firewall to connect to an external host.
-+#
-+#user/pass => external user & password
-+#fwuser/fwpass => firewall user & password
-+#
-+#0) None
-+#1) -----------------------
-+# USER user@remote.host
-+# PASS pass
-+#2) -----------------------
-+# USER fwuser
-+# PASS fwpass
-+# USER user@remote.host
-+# PASS pass
-+#3) -----------------------
-+# USER fwuser
-+# PASS fwpass
-+# SITE remote.site
-+# USER user
-+# PASS pass
-+#4) -----------------------
-+# USER fwuser
-+# PASS fwpass
-+# OPEN remote.site
-+# USER user
-+# PASS pass
-+#5) -----------------------
-+# USER user@fwuser@remote.site
-+# PASS pass@fwpass
-+#6) -----------------------
-+# USER fwuser@remote.site
-+# PASS fwpass
-+# USER user
-+# PASS pass
-+#7) -----------------------
-+# USER user@remote.host
-+# PASS pass
-+# AUTH fwuser
-+# RESP fwpass
-+
-+#Choice:
-+#EDQ
-+# $def = exists $oldcfg{'ftp_firewall_type'} ? $oldcfg{'ftp_firewall_type'} : 1;
-+# $ans = Prompt($msg,$def);
-+# $cfg{'ftp_firewall_type'} = 0+$ans;
-+ $cfg{'ftp_firewall_type'} = 0;
-+# $def = $oldcfg{'ftp_firewall'} || $ENV{FTP_FIREWALL};
-
-- $cfg{'ftp_firewall'} = get_hostname("FTP proxy hostname :", $def);
--}
--else {
-- delete $cfg{'ftp_firewall'};
--}
-+# $cfg{'ftp_firewall'} = get_hostname("FTP proxy hostname :", $def);
-+$cfg{'ftp_firewall'} = $ENV{FTP_FIREWALL};
-
-
- #---------------------------------------------------------------------------
-@@ -489,22 +496,23 @@
-
- #---------------------------------------------------------------------------
-
--print <<EDQ;
--
--Normally when FTP needs a data connection the client tells the server
--a port to connect to, and the server initiates a connection to the client.
--
--Some setups, in particular firewall setups, can/do not work using this
--protocol. In these situations the client must make the connection to the
--server, this is called a passive transfer.
--EDQ
-+#print <<EDQ;
-+#
-+#Normally when FTP needs a data connection the client tells the server
-+#a port to connect to, and the server initiates a connection to the client.
-+#
-+#Some setups, in particular firewall setups, can/do not work using this
-+#protocol. In these situations the client must make the connection to the
-+#server, this is called a passive transfer.
-+#EDQ
-
- if (defined $cfg{'ftp_firewall'}) {
- $msg = "\nShould all FTP connections via a firewall/proxy be passive (y|n) ?";
-
-- $def = $oldcfg{'ftp_ext_passive'} || 0;
-+# $def = $oldcfg{'ftp_ext_passive'} || 0;
-
-- $cfg{'ftp_ext_passive'} = get_bool($msg,$def);
-+# $cfg{'ftp_ext_passive'} = get_bool($msg,$def);
-+ $cfg{'ftp_ext_passive'} = 0;
-
- $msg = "\nShould all other FTP connections be passive (y|n) ?";
-
-@@ -513,18 +521,20 @@
- $msg = "\nShould all FTP connections be passive (y|n) ?";
- }
-
--$def = $oldcfg{'ftp_int_passive'} || 0;
-+#$def = $oldcfg{'ftp_int_passive'} || 0;
-
--$cfg{'ftp_int_passive'} = get_bool($msg,$def);
-+#$cfg{'ftp_int_passive'} = get_bool($msg,$def);
-+$cfg{'ftp_int_passive'} = 0;
-
-
- #---------------------------------------------------------------------------
-
--$def = $oldcfg{'inet_domain'} || $ENV{LOCALDOMAIN};
-+#$def = $oldcfg{'inet_domain'} || $ENV{LOCALDOMAIN};
-
--$ans = Prompt("\nWhat is your local internet domain name :",$def);
-+#$ans = Prompt("\nWhat is your local internet domain name :",$def);
-
--$cfg{'inet_domain'} = ($ans =~ /(\S+)/)[0];
-+#$cfg{'inet_domain'} = ($ans =~ /(\S+)/)[0];
-+$cfg{'inet_domain'} = undef;
-
- #---------------------------------------------------------------------------
-
-@@ -540,7 +550,8 @@
- Do you want me to run these tests (y|n) ?
- EDQ
-
--$cfg{'test_hosts'} = get_bool($msg,$oldcfg{'test_hosts'});
-+#$cfg{'test_hosts'} = get_bool($msg,$oldcfg{'test_hosts'});
-+$cfg{'test_hosts'} = 0;
-
- #---------------------------------------------------------------------------
-
diff --git a/net/p5-Net/pkg-plist b/net/p5-Net/pkg-plist
index 2c90228f01a8..8d4d2cdbcd77 100644
--- a/net/p5-Net/pkg-plist
+++ b/net/p5-Net/pkg-plist
@@ -1,20 +1,20 @@
-lib/perl5/site_perl/%%PERL_VER%%/Net/Cmd.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/Config.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/Domain.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/FTP.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/FTP/A.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/FTP/E.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/FTP/I.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/FTP/L.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/FTP/dataconn.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/NNTP.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/Netrc.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/POP3.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/SMTP.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/Time.pm
-lib/perl5/site_perl/%%PERL_VER%%/Net/libnet.cfg
-lib/perl5/site_perl/%%PERL_VER%%/Net/libnetFAQ.pod
-lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/.packlist
-@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
-@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/FTP
-@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true
+%%SITE_PERL%%/Net/Cmd.pm
+%%SITE_PERL%%/Net/Config.pm
+%%SITE_PERL%%/Net/Domain.pm
+%%SITE_PERL%%/Net/FTP.pm
+%%SITE_PERL%%/Net/FTP/A.pm
+%%SITE_PERL%%/Net/FTP/E.pm
+%%SITE_PERL%%/Net/FTP/I.pm
+%%SITE_PERL%%/Net/FTP/L.pm
+%%SITE_PERL%%/Net/FTP/dataconn.pm
+%%SITE_PERL%%/Net/NNTP.pm
+%%SITE_PERL%%/Net/Netrc.pm
+%%SITE_PERL%%/Net/POP3.pm
+%%SITE_PERL%%/Net/SMTP.pm
+%%SITE_PERL%%/Net/Time.pm
+%%SITE_PERL%%/Net/libnet.cfg
+%%SITE_PERL%%/Net/libnetFAQ.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Net/FTP
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true