aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-10-25 16:57:16 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-10-25 16:57:16 +0000
commitbd0fc2d8ea7db92f4ed96ed0b09535dd8cea0284 (patch)
treefad9d1bd5dee8d115701608542e52b7c086c8c5a /net/p5-Net
parent031be3bf022a7aa34c42a3f5011ae91157b94e6f (diff)
downloadports-bd0fc2d8ea7db92f4ed96ed0b09535dd8cea0284.tar.gz
ports-bd0fc2d8ea7db92f4ed96ed0b09535dd8cea0284.zip
- update dependency
- shorten pkg-descr to make portlint happier - bump PORTREVISION PR: 127823 Submitted by: leeym Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=222059
Diffstat (limited to 'net/p5-Net')
-rw-r--r--net/p5-Net/Makefile14
-rw-r--r--net/p5-Net/pkg-descr96
2 files changed, 24 insertions, 86 deletions
diff --git a/net/p5-Net/Makefile b/net/p5-Net/Makefile
index fb5f38f8cdc2..91f538a2a307 100644
--- a/net/p5-Net/Makefile
+++ b/net/p5-Net/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net
PORTVERSION= 1.22
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net perl5
MASTER_SITES= CPAN
@@ -16,11 +17,9 @@ DISTNAME= libnet-${PORTVERSION}
MAINTAINER= mat@FreeBSD.org
COMMENT= Perl5 modules to access and use network protocols
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL
+RUN_DEPENDS= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
PERL_CONFIGURE= yes
-CONFIGURE_ARGS= < /dev/null
MAN3= Net::Cmd.3 \
Net::Config.3 \
@@ -33,4 +32,11 @@ MAN3= Net::Cmd.3 \
Net::Time.3 \
Net::libnetFAQ.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net/pkg-descr b/net/p5-Net/pkg-descr
index 7ca62ed18c92..1b500d85b011 100644
--- a/net/p5-Net/pkg-descr
+++ b/net/p5-Net/pkg-descr
@@ -1,88 +1,20 @@
-Contents of perl5 Net class:
+libnet is a collection of Perl modules which provides a simple
+and consistent programming interface (API) to the client side
+of various protocols used in the internet community.
-Net::FTP - FTP Client class
+For details of each protocol please refer to the RFC. RFC's
+can be found a various places on the WEB, for a starting
+point look at:
- Net::FTP is a class implementing a simple FTP client in
- Perl as described in RFC959
+ http://www.yahoo.com/Computers_and_Internet/Standards/RFCs/
- Net::FTP provides methods that will perform various
- operations. These methods could be split into groups
- depending the level of interface the user requires.
+ The RFC implemented in this distribution are
-
-Net::Time - time and daytime network client interface
-
- Net::Time provides subroutines that obtain the time on a
- remote machine.
-
-
-Net::DummyInetd - A dummy Inetd server
-
- Net::DummyInetd is just what it's name says, it is a dummy
- inetd server. Creation of a Net::DummyInetd will cause a
- child process to be spawned off which will listen to a
- socket. When a connection arrives on this socket the
- specified command is fork'd and exec'd with STDIN and
- STDOUT file descriptors duplicated to the new socket.
-
-
-Net::NNTP - NNTP Client class
-
- Net::NNTP is a class implementing a simple NNTP client in
- Perl as described in RFC977. Net::NNTP inherits its
- communication methods from Net::Cmd
-
-
-Net::SNPP - Simple Network Pager Protocol Client
-
- This module implements a client interface to the SNPP
- protocol, enabling a perl5 application to talk to SNPP
- servers. This documentation assumes that you are familiar
- with the SNPP protocol described in RFC1861.
-
-
-Net::POP3 - Post Office Protocol 3 Client class (RFC1081)
-
- This module implements a client interface to the POP3
- protocol, enabling a perl5 application to talk to POP3
- servers. This documentation assumes that you are familiar
- with the POP3 protocol described in RFC1081.
-
-
-Net::Cmd - Network Command class (as used by FTP, SMTP etc)
-
- Net::Cmd is a collection of methods that can be inherited
- by a sub class of IO::Handle. These methods implement the
- functionality required for a command based protocol, for
- example FTP and SMTP.
-
-Net::SMTP - Simple Mail transfer Protocol Client
-
- This module implements a client interface to the SMTP
- protocol, enabling a perl5 application to talk to SMTP
- servers. This documentation assumes that you are familiar
- with the SMTP protocol described in RFC821.
-
-
-Net::Domain - Attempt to evaluate the current host's internet name and domain
-
- Using various methods attempt to find the Fully Qualified
- Domain Name (FQDN) of the current host. From this
- determine the host-name and the host-domain.
-
-
-Net::Netrc - OO interface to users netrc file
-
- Net::Netrc is a class implementing a simple interface to
- the .netrc file used as by the ftp program.
-
-
-Net::Telnet - Defines constants for the telnet protocol
-
- This module is VERY preliminary as I am not 100% sure how
- it should be implemented.
-
- Currently it just exports constants used in the telnet
- protocol.
+ Net::FTP RFC959 File Transfer Protocol
+ Net::SMTP RFC821 Simple Mail Transfer Protocol
+ Net::Time RFC867 Daytime Protocol
+ Net::Time RFC868 Time Protocol
+ Net::NNTP RFC977 Network News Transfer Protocol
+ Net::POP3 RFC1939 Post Office Protocol 3
WWW: http://search.cpan.org/dist/libnet/