aboutsummaryrefslogtreecommitdiff
path: root/net/p5-POE-Component-Client-Ident
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-14 09:15:40 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-14 09:15:40 +0000
commitec1e6af90346694a716a530fe59979b6ba3d43ff (patch)
treebc9ab98aded890aaf672199e8ea3f267bd752f43 /net/p5-POE-Component-Client-Ident
parentb6eb45fdd0a82c3616e908acbb6871f686a68523 (diff)
downloadports-ec1e6af90346694a716a530fe59979b6ba3d43ff.tar.gz
ports-ec1e6af90346694a716a530fe59979b6ba3d43ff.zip
Notes
Diffstat (limited to 'net/p5-POE-Component-Client-Ident')
-rw-r--r--net/p5-POE-Component-Client-Ident/Makefile27
-rw-r--r--net/p5-POE-Component-Client-Ident/distinfo3
-rw-r--r--net/p5-POE-Component-Client-Ident/pkg-descr9
-rw-r--r--net/p5-POE-Component-Client-Ident/pkg-plist8
4 files changed, 47 insertions, 0 deletions
diff --git a/net/p5-POE-Component-Client-Ident/Makefile b/net/p5-POE-Component-Client-Ident/Makefile
new file mode 100644
index 000000000000..1a750c74c9fd
--- /dev/null
+++ b/net/p5-POE-Component-Client-Ident/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: POE-Component-Client-Ident
+# Date created: 6 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Client-Ident
+PORTVERSION= 1.00
+CATEGORIES= net perl5 devel
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= POE component for non-blocking ident lookups
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Client::Ident.3 \
+ POE::Component::Client::Ident-Agent.3 \
+ POE::Component::Client::Filter-Ident.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-Client-Ident/distinfo b/net/p5-POE-Component-Client-Ident/distinfo
new file mode 100644
index 000000000000..3366c41e0368
--- /dev/null
+++ b/net/p5-POE-Component-Client-Ident/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-Client-Ident-1.00.tar.gz) = 147645806c8b7ca1ec765bd600671d86
+SHA256 (POE-Component-Client-Ident-1.00.tar.gz) = 883f42b1cc67de3ee1be8cf54c82b0906486fc8b3cbe870570b165868f5a5119
+SIZE (POE-Component-Client-Ident-1.00.tar.gz) = 8966
diff --git a/net/p5-POE-Component-Client-Ident/pkg-descr b/net/p5-POE-Component-Client-Ident/pkg-descr
new file mode 100644
index 000000000000..90a63973ce26
--- /dev/null
+++ b/net/p5-POE-Component-Client-Ident/pkg-descr
@@ -0,0 +1,9 @@
+POE::Component::Client::Ident is a POE component that provides non-
+blocking Ident lookup services to other components and sessions.
+
+The component takes requests in the form of events, spawns
+POE::Component::Client::Ident::Agent sessions to perform the Ident
+queries and returns the appropriate responses to the requesting
+session.
+
+WWW: http://search.cpan.org/dist/POE-Component-Client-Ident/
diff --git a/net/p5-POE-Component-Client-Ident/pkg-plist b/net/p5-POE-Component-Client-Ident/pkg-plist
new file mode 100644
index 000000000000..7f3c52720ca5
--- /dev/null
+++ b/net/p5-POE-Component-Client-Ident/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/POE/Component/Client/Ident.pm
+%%SITE_PERL%%/POE/Component/Client/Ident/Agent.pm
+%%SITE_PERL%%/POE/Filter/Ident.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Ident/.packlist
+@dirrm %%SITE_PERL%%/POE/Component/Client/Ident
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Ident
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component