aboutsummaryrefslogtreecommitdiff
path: root/net/p5-POE-Component-ControlPort
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-02-06 11:38:51 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-02-06 11:38:51 +0000
commit40e15776d7838545b976d3168c0e9cb49416b79f (patch)
treec944714790a1b8722d67040cc97f0b076cfd1f21 /net/p5-POE-Component-ControlPort
parentc0184bdf7db994685f307a2c7ccd6a4da33ce5de (diff)
downloadports-40e15776d7838545b976d3168c0e9cb49416b79f.tar.gz
ports-40e15776d7838545b976d3168c0e9cb49416b79f.zip
Notes
Diffstat (limited to 'net/p5-POE-Component-ControlPort')
-rw-r--r--net/p5-POE-Component-ControlPort/Makefile44
-rw-r--r--net/p5-POE-Component-ControlPort/distinfo3
-rw-r--r--net/p5-POE-Component-ControlPort/pkg-descr7
-rw-r--r--net/p5-POE-Component-ControlPort/pkg-plist7
4 files changed, 61 insertions, 0 deletions
diff --git a/net/p5-POE-Component-ControlPort/Makefile b/net/p5-POE-Component-ControlPort/Makefile
new file mode 100644
index 000000000000..ac3938bd881a
--- /dev/null
+++ b/net/p5-POE-Component-ControlPort/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: net/p5-POE-Component-ControlPort
+# Date created: 05 February 2006
+# Whom: Zach Thompson <hideo@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-ControlPort
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= hideo@lastamericanempire.com
+COMMENT= Network control port for POE applications
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/${PERL_ARCH}/Authen/Libwrap.pm:${PORTSDIR}/security/p5-Authen-Libwrap \
+ ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::ControlPort.3 \
+ POE::Component::ControlPort::Command.3 \
+ POE::Component::ControlPort::DefaultCommands.3
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ @${PERL} -0pi -e 's/my \$$prompt.+(my \$$ret = )(?-s).+/$${1}0;/so' ${WRKSRC}/Makefile.PL
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -pi -e 's/^our (\W\w+);/use vars q($$1);/o;' \
+ -e 's/^our\s+(\W\w+)(?!;)/use vars q($$1); $$1/o;' \
+ -e 'undef $$_ if /^\s*(no|use) warnings/o;' \
+ ${WRKSRC}/lib/POE/Component/ControlPort.pm \
+ ${WRKSRC}/lib/POE/Component/ControlPort/DefaultCommands.pm \
+ ${WRKSRC}/lib/POE/Component/ControlPort/Command.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-POE-Component-ControlPort/distinfo b/net/p5-POE-Component-ControlPort/distinfo
new file mode 100644
index 000000000000..42aece67fdf5
--- /dev/null
+++ b/net/p5-POE-Component-ControlPort/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-ControlPort-0.01.tar.gz) = 7dcbb514606af24e8453031110a6e763
+SHA256 (POE-Component-ControlPort-0.01.tar.gz) = 652bd2b358ffac2d4e4fa729770397f646ce2730d829eef5220e9cab1edab1fb
+SIZE (POE-Component-ControlPort-0.01.tar.gz) = 12182
diff --git a/net/p5-POE-Component-ControlPort/pkg-descr b/net/p5-POE-Component-ControlPort/pkg-descr
new file mode 100644
index 000000000000..b3fd2c630eec
--- /dev/null
+++ b/net/p5-POE-Component-ControlPort/pkg-descr
@@ -0,0 +1,7 @@
+When building network applications, it is often helpful to have
+a network accessible control and diagnostic interface. This module
+provides such an interface for POE applications. By default, it
+provides a fairly limited set of commands but is easily extended
+to provide whatever command set you require.
+
+WWW: http://search.cpan.org/dist/POE-Component-ControlPort
diff --git a/net/p5-POE-Component-ControlPort/pkg-plist b/net/p5-POE-Component-ControlPort/pkg-plist
new file mode 100644
index 000000000000..2f2217ad80f9
--- /dev/null
+++ b/net/p5-POE-Component-ControlPort/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/POE/Component/ControlPort.pm
+%%SITE_PERL%%/POE/Component/ControlPort/Command.pm
+%%SITE_PERL%%/POE/Component/ControlPort/DefaultCommands.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/ControlPort/.packlist
+@dirrm %%SITE_PERL%%/POE/Component/ControlPort
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/ControlPort
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component