aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Parallel-MPI/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-10-15 08:50:37 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-10-15 08:50:37 +0000
commit0d004c90d488a4ea6dc74bb6124209a145e8c151 (patch)
tree7e5082fe86c55674386788fbcb857efa95f29f5b /net/p5-Parallel-MPI/Makefile
parent56b7bf675d8124831a9d4acb07096b2c3df766b7 (diff)
downloadports-0d004c90d488a4ea6dc74bb6124209a145e8c151.tar.gz
ports-0d004c90d488a4ea6dc74bb6124209a145e8c151.zip
Notes
Diffstat (limited to 'net/p5-Parallel-MPI/Makefile')
-rw-r--r--net/p5-Parallel-MPI/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/p5-Parallel-MPI/Makefile b/net/p5-Parallel-MPI/Makefile
new file mode 100644
index 000000000000..ae7a436ad756
--- /dev/null
+++ b/net/p5-Parallel-MPI/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Parallel-MPI
+# Date created: 06 March 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parallel-MPI
+PORTVERSION= 0.03
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parallel
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Perl interface to the MPI message passing system
+
+BUILD_DEPENDS= ${LOCALBASE}/mpich/bin/mpicc:${PORTSDIR}/net/mpich
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+CC= ${PREFIX}/mpich/bin/mpicc
+CONFIGURE_ARGS= LD="${PREFIX}/mpich/bin/mpicc" INC="-I${PREFIX}/mpich/include"
+
+MAN3= Parallel::MPI.3
+
+.include <bsd.port.mk>