aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Parallel-Pvm
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2003-10-15 09:53:40 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2003-10-15 09:53:40 +0000
commit19ce80f8c16814d437bde614de98a2621d2e008f (patch)
treeeced298a6b8383578787b28125aead909ad3418c /net/p5-Parallel-Pvm
parent49ed9decb0aff8048caf1a1877fa17d4ba0e65bf (diff)
downloadports-19ce80f8c16814d437bde614de98a2621d2e008f.tar.gz
ports-19ce80f8c16814d437bde614de98a2621d2e008f.zip
Notes
Diffstat (limited to 'net/p5-Parallel-Pvm')
-rw-r--r--net/p5-Parallel-Pvm/Makefile29
-rw-r--r--net/p5-Parallel-Pvm/distinfo1
-rw-r--r--net/p5-Parallel-Pvm/pkg-descr22
-rw-r--r--net/p5-Parallel-Pvm/pkg-plist10
4 files changed, 62 insertions, 0 deletions
diff --git a/net/p5-Parallel-Pvm/Makefile b/net/p5-Parallel-Pvm/Makefile
new file mode 100644
index 000000000000..7ee7d52dfbe1
--- /dev/null
+++ b/net/p5-Parallel-Pvm/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Parallel-Pvm
+# Date created: 15 October 2003
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parallel-Pvm
+PORTVERSION= 1.3.0
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parallel
+PKGNAMEPREFIX= p5-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Perl extension for the Parallel Virtual Machine (PVM)
+
+BUILD_DEPENDS= pvm:${PORTSDIR}/net/pvm
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+PVM_ROOT= ${PREFIX}/lib/pvm
+CONFIGURE_ENV= PVM_ROOT="${PVM_ROOT}" PVM_ARCH="${PVM_ROOT}/lib/pvmgetarch"
+CONFIGURE_ARGS= INC="-I${PREFIX}/include"
+
+MAN3= Parallel::Pvm.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Parallel-Pvm/distinfo b/net/p5-Parallel-Pvm/distinfo
new file mode 100644
index 000000000000..ecb4d83dae4c
--- /dev/null
+++ b/net/p5-Parallel-Pvm/distinfo
@@ -0,0 +1 @@
+MD5 (Parallel-Pvm-1.3.0.tgz) = 2e228cec03885e7ad3e215cfc444a0fd
diff --git a/net/p5-Parallel-Pvm/pkg-descr b/net/p5-Parallel-Pvm/pkg-descr
new file mode 100644
index 000000000000..bdb9d9bd238c
--- /dev/null
+++ b/net/p5-Parallel-Pvm/pkg-descr
@@ -0,0 +1,22 @@
+Paraller::Pvm is a perl interface to the Parallel Virtual Machine (PVM)
+Message Passing System.
+
+The PVM message passing system enables a programmer to configure a group
+of (possibly heterogenous) computers connected by a network into a
+parallel virtual machine.
+
+Using PVM, applications can be developed which spawns parallel processes
+onto nodes in the virtual machine to perform specific tasks. These
+parallel tasks can also periodically exchange information using a set of
+message passing functions developed for the system.
+
+PVM applications have mostly been developed in the scientific and
+engineering fields. However applications for real-time and
+client/server systems can also be developed. PVM simply provides a
+convenient way for managing parallel tasks and communications without
+need for rexec or socket level programming.
+
+WWW: http://search.cpan.org/dist/Parallel-Pvm/
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/net/p5-Parallel-Pvm/pkg-plist b/net/p5-Parallel-Pvm/pkg-plist
new file mode 100644
index 000000000000..425cfecc9e89
--- /dev/null
+++ b/net/p5-Parallel-Pvm/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Parallel/Pvm.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel/Pvm/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel/Pvm/Pvm.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel/Pvm/Pvm.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel/Pvm/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel/Pvm/code2symbol.al
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel/Pvm/code2text.al
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel/Pvm
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Parallel 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parallel 2>/dev/null || true