aboutsummaryrefslogtreecommitdiff
path: root/net/p5-REST-Application
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2007-06-04 03:54:37 +0000
committerAaron Dalton <aaron@FreeBSD.org>2007-06-04 03:54:37 +0000
commit451c555931f03d0d8754ce26f9da1583c8729ac9 (patch)
tree9bd06c2d491cda21112271c6dd07ca412c844c26 /net/p5-REST-Application
parentd1366631f44f383fe2fa0342e9252bf53bc83e39 (diff)
downloadports-451c555931f03d0d8754ce26f9da1583c8729ac9.tar.gz
ports-451c555931f03d0d8754ce26f9da1583c8729ac9.zip
Notes
Diffstat (limited to 'net/p5-REST-Application')
-rw-r--r--net/p5-REST-Application/Makefile26
-rw-r--r--net/p5-REST-Application/distinfo3
-rw-r--r--net/p5-REST-Application/pkg-descr9
-rw-r--r--net/p5-REST-Application/pkg-plist7
4 files changed, 45 insertions, 0 deletions
diff --git a/net/p5-REST-Application/Makefile b/net/p5-REST-Application/Makefile
new file mode 100644
index 000000000000..be0e65889b57
--- /dev/null
+++ b/net/p5-REST-Application/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-REST-Application
+# Date created: 04 June 2007
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= REST-Application
+PORTVERSION= 0.991
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/M/MO/MOCONNOR/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A framework for building RESTful web-applications
+
+BUILD_DEPENDS= p5-Tie-IxHash>=0:${PORTSDIR}/devel/p5-Tie-IxHash
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= REST::Application.3 \
+ REST::Application::Routes.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/p5-REST-Application/distinfo b/net/p5-REST-Application/distinfo
new file mode 100644
index 000000000000..8e39d22e8e5a
--- /dev/null
+++ b/net/p5-REST-Application/distinfo
@@ -0,0 +1,3 @@
+MD5 (REST-Application-0.991.tar.gz) = eaea5eacc43efab0e70059f691e0d5d6
+SHA256 (REST-Application-0.991.tar.gz) = a1dc1cbe5b244a1eb1ebbb26f43787bd525dd8cf786f9656532f6af004a0a99b
+SIZE (REST-Application-0.991.tar.gz) = 25976
diff --git a/net/p5-REST-Application/pkg-descr b/net/p5-REST-Application/pkg-descr
new file mode 100644
index 000000000000..09fd801e9ca2
--- /dev/null
+++ b/net/p5-REST-Application/pkg-descr
@@ -0,0 +1,9 @@
+This module acts as a base class for applications which implement a
+RESTful interface. When an HTTP request is received some dispatching logic
+in REST::Application is invoked, calling different handlers based on what
+the kind of HTTP request it was (i.e. GET, PUT, etc) and what resource it
+was trying to access. This module won't ensure that your API is RESTful
+but hopefully it will aid in developing a REST API.
+
+WWW: http://search.cpan.org/dist/REST-Application
+Author: Matthew O'Connor <matthew@canonical.org>
diff --git a/net/p5-REST-Application/pkg-plist b/net/p5-REST-Application/pkg-plist
new file mode 100644
index 000000000000..500fceeb3dd7
--- /dev/null
+++ b/net/p5-REST-Application/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/REST/Application.pm
+%%SITE_PERL%%/REST/Application/Routes.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/REST/Application/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/REST/Application
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/REST
+@dirrm %%SITE_PERL%%/REST/Application
+@dirrm %%SITE_PERL%%/REST