aboutsummaryrefslogtreecommitdiff
path: root/net/p5-RPC-Simple/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 07:02:36 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 07:02:36 +0000
commit373af94e47f1a137dcc0c60ce700d60579e6bb5f (patch)
treed5826cd5ce993a53504cf4263bf88737e20bbb2f /net/p5-RPC-Simple/Makefile
parent3f861d0268c0b949ce8442c581262646136b5d11 (diff)
downloadports-373af94e47f1a137dcc0c60ce700d60579e6bb5f.tar.gz
ports-373af94e47f1a137dcc0c60ce700d60579e6bb5f.zip
Notes
Diffstat (limited to 'net/p5-RPC-Simple/Makefile')
-rw-r--r--net/p5-RPC-Simple/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/net/p5-RPC-Simple/Makefile b/net/p5-RPC-Simple/Makefile
new file mode 100644
index 000000000000..2ebfd1cbff4a
--- /dev/null
+++ b/net/p5-RPC-Simple/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-RPC-Simple
+# Date created: 2006-08-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RPC-Simple
+PORTVERSION= 1.002
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= RPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl classes to handle simple asynchronous RPC calls with call-back
+
+PERL_CONFIGURE= yes
+
+MAN3= RPC::Simple.3 RPC::Simple::Agent.3 RPC::Simple::AnyLocal.3 \
+ RPC::Simple::AnyRemote.3 RPC::Simple::AnyWhere.3 \
+ RPC::Simple::CallHandler.3 RPC::Simple::Factory.3 \
+ RPC::Simple::ObjectHandler.3 RPC::Simple::Server.3
+
+.include <bsd.port.mk>