aboutsummaryrefslogtreecommitdiff
path: root/net/p5-RPC-XML
diff options
context:
space:
mode:
authorAlan Eldridge <alane@FreeBSD.org>2002-11-23 17:47:49 +0000
committerAlan Eldridge <alane@FreeBSD.org>2002-11-23 17:47:49 +0000
commitd971cd249b512ad864eaa549e61a06b22d8b6b6c (patch)
treefef2a51dd6e9f3eccb5f3ae694be2f7498d3e84f /net/p5-RPC-XML
parent6ab4e36838754937b67e4fce84b174001f82afa4 (diff)
downloadports-d971cd249b512ad864eaa549e61a06b22d8b6b6c.tar.gz
ports-d971cd249b512ad864eaa549e61a06b22d8b6b6c.zip
Notes
Diffstat (limited to 'net/p5-RPC-XML')
-rw-r--r--net/p5-RPC-XML/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/net/p5-RPC-XML/Makefile b/net/p5-RPC-XML/Makefile
index d7a201b62b35..c0d9f6460000 100644
--- a/net/p5-RPC-XML/Makefile
+++ b/net/p5-RPC-XML/Makefile
@@ -14,8 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= dom@happygiraffe.net
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -28,4 +27,21 @@ MAN3= Apache::RPC::Server.3 \
RPC::XML::Client.3 \
RPC::XML::Parser.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+perl_major= ${PERL_VERSION:C|^([1-9]+).*|\1|}
+_perl_minor= 00${PERL_VERSION:C|^([1-9]+)\.([0-9]+).*|\2|}
+perl_minor= ${_perl_minor:C|^.*(...)|\1|}
+.if ${perl_minor} >= 100
+perl_minor= ${PERL_VERSION:C|^([1-9]+)\.([0-9][0-9][0-9]).*|\2|}
+perl_patch= ${PERL_VERSION:C|^.*(..)|\1|}
+.else # ${perl_minor} < 100
+_perl_patch= 0${PERL_VERSION:C|^([1-9]+)\.([0-9]+)\.*|0|}
+perl_patch= ${_perl_patch:C|^.*(..)|\1|}
+.endif # ${perl_minor} < 100
+PERL_LEVEL= ${perl_major}${perl_minor}${perl_patch}
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif # ${PERL_LEVEL} < 500601
+
+.include <bsd.port.post.mk>