aboutsummaryrefslogtreecommitdiff
path: root/net/p5-RRD-Simple/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-05 10:53:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-05 10:53:21 +0000
commita6f9551ae0f67817e816acd098d44c20be9d8402 (patch)
tree1d422057b9ae218aa2624835bef21e3f039fb031 /net/p5-RRD-Simple/Makefile
parentd9a3bcb4d9175f2f780e19c1637658725ac55bdd (diff)
downloadports-a6f9551ae0f67817e816acd098d44c20be9d8402.tar.gz
ports-a6f9551ae0f67817e816acd098d44c20be9d8402.zip
Notes
Diffstat (limited to 'net/p5-RRD-Simple/Makefile')
-rw-r--r--net/p5-RRD-Simple/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net/p5-RRD-Simple/Makefile b/net/p5-RRD-Simple/Makefile
new file mode 100644
index 000000000000..62e59d8e8263
--- /dev/null
+++ b/net/p5-RRD-Simple/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: RRD-Simple
+# Date created: 2006/07/21
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RRD-Simple
+PORTVERSION= 1.39
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/N/NI/NICOLAW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Simple interface to create and store data in RRD files
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Deep.pm:${PORTSDIR}/devel/p5-Test-Deep \
+ p5-Test-Pod>=0.90:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>0:${PORTSDIR}/devel/p5-Test-Pod-Coverage \
+ ${SITE_PERL}/${PERL_ARCH}/RRDs.pm:${PORTSDIR}/net/rrdtool
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+MAN3= RRD::Simple.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or higher. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>