aboutsummaryrefslogtreecommitdiff
path: root/net/p5-SNMP/Makefile
diff options
context:
space:
mode:
authorJames FitzGibbon <jfitz@FreeBSD.org>1997-06-27 01:53:14 +0000
committerJames FitzGibbon <jfitz@FreeBSD.org>1997-06-27 01:53:14 +0000
commit2841c2f4fed9bedd1af323ac2d0b36d5e2340db7 (patch)
tree2f8ed2babe6f89a0811e4a434db399ac48ce2401 /net/p5-SNMP/Makefile
parent0892424656a01d0b60febdf52e4f15966a5aac43 (diff)
Import of a perl5 interface to UCD's SNMP library
Notes
Notes: svn path=/head/; revision=7085
Diffstat (limited to 'net/p5-SNMP/Makefile')
-rw-r--r--net/p5-SNMP/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/p5-SNMP/Makefile b/net/p5-SNMP/Makefile
new file mode 100644
index 000000000000..4ffdc8f3baba
--- /dev/null
+++ b/net/p5-SNMP/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-SNMP
+# Version required: 1.6
+# Date created: May 5th 1997
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $Id$
+#
+
+DISTNAME= SNMP-1.6
+PKGNAME= p5-SNMP-1.6
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SNMP
+
+MAINTAINER= jfitz@FreeBSD.ORG
+
+BUILD_DEPENDS= ${PREFIX}/lib/libsnmp.a:${PORTSDIR}/net/ucd-snmp
+
+USE_PERL5= YES
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PREFIX}/bin/perl Makefile.PL
+
+post-install:
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/lib/perl5/site_perl/README.SNMP
+
+.include <bsd.port.mk>