aboutsummaryrefslogtreecommitdiff
path: root/net/p5-SOAP-Lite/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-28 19:06:01 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-28 19:06:01 +0000
commit73a70cacb0a0f8ae2498861a7280431f1c1d24cf (patch)
tree8c149e0e86e3de6908461833ca54ab9454d16cea /net/p5-SOAP-Lite/Makefile
parentf9e4531b39785d7026206ae0f6b99e8a7a450108 (diff)
downloadports-73a70cacb0a0f8ae2498861a7280431f1c1d24cf.tar.gz
ports-73a70cacb0a0f8ae2498861a7280431f1c1d24cf.zip
Notes
Diffstat (limited to 'net/p5-SOAP-Lite/Makefile')
-rw-r--r--net/p5-SOAP-Lite/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/net/p5-SOAP-Lite/Makefile b/net/p5-SOAP-Lite/Makefile
index 54a98989b23a..26f79bf0fc41 100644
--- a/net/p5-SOAP-Lite/Makefile
+++ b/net/p5-SOAP-Lite/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= SOAP-Lite
-PORTVERSION= 1.13
+PORTVERSION= 1.14
CATEGORIES= net perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,18 +13,19 @@ COMMENT= Client and server side SOAP implementation
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-BUILD_DEPENDS= \
- p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
- p5-URI>=0:${PORTSDIR}/net/p5-URI \
+BUILD_DEPENDS= p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
p5-IO-SessionData>=1.03:${PORTSDIR}/devel/p5-IO-SessionData \
- p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
- p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-LWP-Protocol-https>=0:${PORTSDIR}/www/p5-LWP-Protocol-https \
+ p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
p5-Task-Weaken>=0:${PORTSDIR}/devel/p5-Task-Weaken \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-XML-Parser>=2.23:${PORTSDIR}/textproc/p5-XML-Parser \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
- p5-MIME-Tools>=0:${PORTSDIR}/mail/p5-MIME-Tools \
-
+ p5-XML-Parser-Lite>=0:${PORTSDIR}/textproc/p5-XML-Parser-Lite \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Warn>=0:${PORTSDIR}/devel/p5-Test-Warn \
+ p5-Test-XML>=0:${PORTSDIR}/devel/p5-Test-XML
CONFLICTS= p5-SOAP-Lite-0.60* p5-SOAP-[0-9]*
@@ -34,8 +35,6 @@ USE_PERL5= configure
USES= perl5 shebangfix
NO_ARCH= yes
-#pre-install: test
-
SHEBANG_FILES= bin/SOAPsh.pl
perl_OLD_CMD= .*perl