aboutsummaryrefslogtreecommitdiff
path: root/net/p5-SOAP-Lite
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-05-28 12:52:10 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-05-28 12:52:10 +0000
commit3e0e9e9641ad9750eae0e8a75eb9700f68ff49b0 (patch)
tree07eecafdf6bed3934aa6c7a780f41d6f590bfd53 /net/p5-SOAP-Lite
parentbc4f1b78103f2bc22a8203bcf6d4406d1a97b757 (diff)
downloadports-3e0e9e9641ad9750eae0e8a75eb9700f68ff49b0.tar.gz
ports-3e0e9e9641ad9750eae0e8a75eb9700f68ff49b0.zip
Notes
Diffstat (limited to 'net/p5-SOAP-Lite')
-rw-r--r--net/p5-SOAP-Lite/Makefile43
-rw-r--r--net/p5-SOAP-Lite/distinfo1
-rw-r--r--net/p5-SOAP-Lite/files/patch-Makefile.PL24
-rw-r--r--net/p5-SOAP-Lite/pkg-comment1
-rw-r--r--net/p5-SOAP-Lite/pkg-descr3
-rw-r--r--net/p5-SOAP-Lite/pkg-plist28
6 files changed, 100 insertions, 0 deletions
diff --git a/net/p5-SOAP-Lite/Makefile b/net/p5-SOAP-Lite/Makefile
new file mode 100644
index 000000000000..3760ef691821
--- /dev/null
+++ b/net/p5-SOAP-Lite/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: p5-SOAP-Lite
+# Date created: May 28 2001
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= SOAP-Lite
+PORTVERSION= 0.50
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SOAP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MIME/Tools.pm:${PORTSDIR}/mail/p5-MIME-Tools \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Crypt/SSLeay.pm:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= SOAPsh.pl.1
+MAN3PREFIX= ${LOCALBASE}/lib/perl5/${PERL_VERSION}
+MAN3= Apache::SOAP.3 \
+ SOAP::Lite.3 \
+ SOAP::Test.3 \
+ SOAP::Transport::FTP.3 \
+ SOAP::Transport::HTTP.3 \
+ SOAP::Transport::IO.3 \
+ SOAP::Transport::LOCAL.3 \
+ SOAP::Transport::MAILTO.3 \
+ SOAP::Transport::POP3.3 \
+ SOAP::Transport::TCP.3 \
+ UDDI::Lite.3 \
+ XML::Parser::Lite.3 \
+ XMLRPC::Lite.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-SOAP-Lite/distinfo b/net/p5-SOAP-Lite/distinfo
new file mode 100644
index 000000000000..d9d0c6c1cfe4
--- /dev/null
+++ b/net/p5-SOAP-Lite/distinfo
@@ -0,0 +1 @@
+MD5 (SOAP-Lite-0.50.tar.gz) = a5d50d9d56fc7dfaa9cbf02155c9bf7d
diff --git a/net/p5-SOAP-Lite/files/patch-Makefile.PL b/net/p5-SOAP-Lite/files/patch-Makefile.PL
new file mode 100644
index 000000000000..456f34773448
--- /dev/null
+++ b/net/p5-SOAP-Lite/files/patch-Makefile.PL
@@ -0,0 +1,24 @@
+--- Makefile.PL.orig Mon May 28 17:12:36 2001
++++ Makefile.PL Mon May 28 17:14:23 2001
+@@ -55,7 +55,7 @@
+ EOI
+
+ my %prerequisites;
+-my $auto = ExtUtils::MakeMaker::prompt("\nDo you want to proceed with this configuration?" => 'yes') =~ /^\s*y/i;
++my $auto = "y";
+
+ foreach (split /(^[-\s]+$)/m, $prerequisites) {
+ print unless $auto;
+@@ -67,11 +67,7 @@
+ }
+ }
+
+-my $noncoretests = ExtUtils::MakeMaker::prompt('
+-During "make test" phase we may run tests with several SOAP servers
+-that may take long and may fail due to server/connectivity problems.
+-
+-Do you want to perform these tests in addition to core tests?', 'no') =~ /^\s*(y)/i;
++my $noncoretests = "n";
+
+ my $tests = join ' ', glob ($noncoretests ? 't/*.t' : 't/0*.t');
+
diff --git a/net/p5-SOAP-Lite/pkg-comment b/net/p5-SOAP-Lite/pkg-comment
new file mode 100644
index 000000000000..8d408093e769
--- /dev/null
+++ b/net/p5-SOAP-Lite/pkg-comment
@@ -0,0 +1 @@
+SOAP::Lite - Client and server side SOAP implementation
diff --git a/net/p5-SOAP-Lite/pkg-descr b/net/p5-SOAP-Lite/pkg-descr
new file mode 100644
index 000000000000..050481b99ea2
--- /dev/null
+++ b/net/p5-SOAP-Lite/pkg-descr
@@ -0,0 +1,3 @@
+SOAP::Lite is a collection of Perl modules which provides a
+simple and lightweight interface to the Simple Object Access Protocol
+(SOAP) both on client and server side.
diff --git a/net/p5-SOAP-Lite/pkg-plist b/net/p5-SOAP-Lite/pkg-plist
new file mode 100644
index 000000000000..f48a65f07926
--- /dev/null
+++ b/net/p5-SOAP-Lite/pkg-plist
@@ -0,0 +1,28 @@
+bin/SOAPsh.pl
+bin/stubmaker.pl
+lib/perl5/site_perl/%%PERL_VER%%/Apache/SOAP.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Lite.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Test.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/FTP.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/HTTP.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/IO.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/LOCAL.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/MAILTO.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/POP3.pm
+lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport/TCP.pm
+lib/perl5/site_perl/%%PERL_VER%%/UDDI/Lite.pm
+lib/perl5/site_perl/%%PERL_VER%%/XML/Parser/Lite.pm
+lib/perl5/site_perl/%%PERL_VER%%/XMLRPC/Lite.pm
+lib/perl5/site_perl/%%PERL_VER%%/XMLRPC/Transport/HTTP.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SOAP/Lite/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SOAP/Lite
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/SOAP 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/XMLRPC/Transport
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/XMLRPC
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/SOAP/Transport
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/SOAP 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML/Parser 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Apache 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/SOAP 2>/dev/null || true
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/UDDI