aboutsummaryrefslogtreecommitdiff
path: root/net/p5-URI-Match
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2011-09-09 02:26:22 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2011-09-09 02:26:22 +0000
commit5ef40621959ba42a4f04a8933eaf60b5c0db32d1 (patch)
treeea37684da15211416f8fb0545265961e156b9053 /net/p5-URI-Match
parent4e347ced58ba2809d0631b34db81e001c577c360 (diff)
downloadports-5ef40621959ba42a4f04a8933eaf60b5c0db32d1.tar.gz
ports-5ef40621959ba42a4f04a8933eaf60b5c0db32d1.zip
Notes
Diffstat (limited to 'net/p5-URI-Match')
-rw-r--r--net/p5-URI-Match/Makefile25
-rw-r--r--net/p5-URI-Match/distinfo2
-rw-r--r--net/p5-URI-Match/pkg-descr13
-rw-r--r--net/p5-URI-Match/pkg-plist3
4 files changed, 43 insertions, 0 deletions
diff --git a/net/p5-URI-Match/Makefile b/net/p5-URI-Match/Makefile
new file mode 100644
index 000000000000..0c73a641fe57
--- /dev/null
+++ b/net/p5-URI-Match/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: URI::Match
+# Date created: 09 Sep 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= URI-Match
+PORTVERSION= 0.00001
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for matching URLs by parts
+
+RUN_DEPENDS= \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= URI::Match.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-URI-Match/distinfo b/net/p5-URI-Match/distinfo
new file mode 100644
index 000000000000..baafc70b1118
--- /dev/null
+++ b/net/p5-URI-Match/distinfo
@@ -0,0 +1,2 @@
+SHA256 (URI-Match-0.00001.tar.gz) = 80be56c6591b6a17b8217cf9c03ba910d6ab0537d7a01c43dccc6bf7e567ca84
+SIZE (URI-Match-0.00001.tar.gz) = 13163
diff --git a/net/p5-URI-Match/pkg-descr b/net/p5-URI-Match/pkg-descr
new file mode 100644
index 000000000000..57883ed6d299
--- /dev/null
+++ b/net/p5-URI-Match/pkg-descr
@@ -0,0 +1,13 @@
+This is a simple utility that adds ability to match URL parts against
+regular expressions, subroutines, or objects that implement a match()
+method.
+
+Since this module uses loops and method calls, writing up a clever
+regular expression and using it directly against the whole URL is
+probably faster. This module aims to solve the problem where
+readability matters, or when you need to assemble the match conditions
+at run time.
+
+URI::Match adds the following methods to the URI namespace.
+
+WWW: http://search.cpan.org/dist/URI-Match/
diff --git a/net/p5-URI-Match/pkg-plist b/net/p5-URI-Match/pkg-plist
new file mode 100644
index 000000000000..7cebd168acb7
--- /dev/null
+++ b/net/p5-URI-Match/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/Match/.packlist
+%%SITE_PERL%%/URI/Match.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/URI/Match