aboutsummaryrefslogtreecommitdiff
path: root/net/p5-XML-Compile-SOAP-Daemon
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2008-04-15 07:32:40 +0000
committerLars Thegler <lth@FreeBSD.org>2008-04-15 07:32:40 +0000
commit65361e4c1513ab57c43231260ef165189822c157 (patch)
tree96f85ee781e52c834bf5f4e321a1b12c8653ea75 /net/p5-XML-Compile-SOAP-Daemon
parentf2b749c20a2a45e14b7b83ef392d1d54f2c9d1bf (diff)
downloadports-65361e4c1513ab57c43231260ef165189822c157.tar.gz
ports-65361e4c1513ab57c43231260ef165189822c157.zip
Notes
Diffstat (limited to 'net/p5-XML-Compile-SOAP-Daemon')
-rw-r--r--net/p5-XML-Compile-SOAP-Daemon/Makefile30
-rw-r--r--net/p5-XML-Compile-SOAP-Daemon/distinfo3
-rw-r--r--net/p5-XML-Compile-SOAP-Daemon/pkg-descr5
-rw-r--r--net/p5-XML-Compile-SOAP-Daemon/pkg-plist12
4 files changed, 50 insertions, 0 deletions
diff --git a/net/p5-XML-Compile-SOAP-Daemon/Makefile b/net/p5-XML-Compile-SOAP-Daemon/Makefile
new file mode 100644
index 000000000000..106419b61790
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-Daemon/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: net/p5-XML-Compile-SOAP-Daemon
+# Date created: 15 April 2008
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-Compile-SOAP-Daemon
+PORTVERSION= 0.10
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Base class for SOAP message servers
+
+BUILD_DEPENDS= p5-Net-Server>=0.97:${PORTSDIR}/net/p5-Net-Server \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes \
+ p5-libwww>=5.803:${PORTSDIR}/www/p5-libwww \
+ p5-Log-Report>=0.15:${PORTSDIR}/devel/p5-Log-Report \
+ p5-XML-Compile-SOAP>=0.56:${PORTSDIR}/net/p5-XML-Compile-SOAP \
+ p5-XML-Compile>=0.55:${PORTSDIR}/textproc/p5-XML-Compile
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= XML::Compile::SOAP::Daemon.3 \
+ XML::Compile::SOAP::HTTPDaemon.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-XML-Compile-SOAP-Daemon/distinfo b/net/p5-XML-Compile-SOAP-Daemon/distinfo
new file mode 100644
index 000000000000..1dd03ac7ab86
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-Daemon/distinfo
@@ -0,0 +1,3 @@
+MD5 (XML-Compile-SOAP-Daemon-0.10.tar.gz) = 1686f44517990cdd69ffb7de857a2949
+SHA256 (XML-Compile-SOAP-Daemon-0.10.tar.gz) = b3fd19498d17f0cf98cf003c71913371acf1e8fb15c845d9ac0f04b654bb8dda
+SIZE (XML-Compile-SOAP-Daemon-0.10.tar.gz) = 19989
diff --git a/net/p5-XML-Compile-SOAP-Daemon/pkg-descr b/net/p5-XML-Compile-SOAP-Daemon/pkg-descr
new file mode 100644
index 000000000000..9f7b892d3fb3
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-Daemon/pkg-descr
@@ -0,0 +1,5 @@
+This base class implements the common needs between various types
+of SOAP daemons. As daemon type, you can use any kind of Net::Server
+implementation.
+
+WWW: http://search.cpan.org/dist/XML-Compile-SOAP-Daemon/
diff --git a/net/p5-XML-Compile-SOAP-Daemon/pkg-plist b/net/p5-XML-Compile-SOAP-Daemon/pkg-plist
new file mode 100644
index 000000000000..2a5cc6787eb3
--- /dev/null
+++ b/net/p5-XML-Compile-SOAP-Daemon/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/XML/Compile/SOAP/Daemon.pm
+%%SITE_PERL%%/XML/Compile/SOAP/Daemon.pod
+%%SITE_PERL%%/XML/Compile/SOAP/HTTPDaemon.pm
+%%SITE_PERL%%/XML/Compile/SOAP/HTTPDaemon.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/Daemon/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP/Daemon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile/SOAP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML/Compile
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/XML
+@dirrmtry %%SITE_PERL%%/XML/Compile/SOAP
+@dirrmtry %%SITE_PERL%%/XML/Compile
+@dirrmtry %%SITE_PERL%%/XML