aboutsummaryrefslogtreecommitdiff
path: root/net/p5-XPC
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-30 11:38:50 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-30 11:38:50 +0000
commit1b5b822f96aea37e2bd621eb8ba2a3f09d86a18e (patch)
tree2607abf78e4c8d0f16c4f5170d167b04faa6eda1 /net/p5-XPC
parent2e59db1da0735b76575d093d0e99b37029daacb4 (diff)
downloadports-1b5b822f96aea37e2bd621eb8ba2a3f09d86a18e.tar.gz
ports-1b5b822f96aea37e2bd621eb8ba2a3f09d86a18e.zip
Notes
Diffstat (limited to 'net/p5-XPC')
-rw-r--r--net/p5-XPC/Makefile27
-rw-r--r--net/p5-XPC/distinfo1
-rw-r--r--net/p5-XPC/pkg-comment1
-rw-r--r--net/p5-XPC/pkg-descr3
-rw-r--r--net/p5-XPC/pkg-plist7
5 files changed, 39 insertions, 0 deletions
diff --git a/net/p5-XPC/Makefile b/net/p5-XPC/Makefile
new file mode 100644
index 000000000000..d71b793e8c8c
--- /dev/null
+++ b/net/p5-XPC/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: p5-XPC
+# Date created: May 30, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= XPC
+PORTVERSION= 0.2
+CATEGORIES= net perl5
+MASTER_SITES= http://www.focusresearch.com/gregor/sw/XPC/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTTP/Daemon.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/URI.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= XPC.3 XPC::Agent.3 XPC::Daemon.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-XPC/distinfo b/net/p5-XPC/distinfo
new file mode 100644
index 000000000000..7f28501c96a4
--- /dev/null
+++ b/net/p5-XPC/distinfo
@@ -0,0 +1 @@
+MD5 (XPC-0.2.tar.gz) = 8ba1fa7b7c13c08eae5a3f633d53ab68
diff --git a/net/p5-XPC/pkg-comment b/net/p5-XPC/pkg-comment
new file mode 100644
index 000000000000..32ac85e8ec89
--- /dev/null
+++ b/net/p5-XPC/pkg-comment
@@ -0,0 +1 @@
+XML Procedure Call (XPC)
diff --git a/net/p5-XPC/pkg-descr b/net/p5-XPC/pkg-descr
new file mode 100644
index 000000000000..c57b98aeebf5
--- /dev/null
+++ b/net/p5-XPC/pkg-descr
@@ -0,0 +1,3 @@
+This class represents an XPC request or response.
+
+WWW: http://www.focusresearch.com/gregor/sw/XPC/
diff --git a/net/p5-XPC/pkg-plist b/net/p5-XPC/pkg-plist
new file mode 100644
index 000000000000..90afb3f8fbfb
--- /dev/null
+++ b/net/p5-XPC/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/XPC.pm
+lib/perl5/site_perl/%%PERL_VER%%/XPC/Agent.pm
+lib/perl5/site_perl/%%PERL_VER%%/XPC/Daemon.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/XPC
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XPC/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XPC
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto