aboutsummaryrefslogtreecommitdiff
path: root/net/pathchar/Makefile
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1998-11-15 21:25:16 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1998-11-15 21:25:16 +0000
commit15b58fe6a1b27d6049c9366fd92b0b46e49abbd0 (patch)
tree726e38faca6999c75741f1810255586350b6c4bb /net/pathchar/Makefile
parentdf912b9261c9c56afbfc5577ca7d0e1164bb4457 (diff)
downloadports-15b58fe6a1b27d6049c9366fd92b0b46e49abbd0.tar.gz
ports-15b58fe6a1b27d6049c9366fd92b0b46e49abbd0.zip
Notes
Diffstat (limited to 'net/pathchar/Makefile')
-rw-r--r--net/pathchar/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/net/pathchar/Makefile b/net/pathchar/Makefile
new file mode 100644
index 000000000000..8e944e42afbc
--- /dev/null
+++ b/net/pathchar/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: pathchar
+# Version required: a0 (a.out systems), a1 (ELF systems)
+# Date created: 7 November 1998
+# Whom: Josh Gilliam <josh@quick.net>
+#
+# $Id$
+#
+
+DISTNAME= pathchar-a1-freebsd-3.0
+PKGNAME= pathchar-a1
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.ee.lbl.gov/pathchar/
+
+MAINTAINER= josh@quick.net
+
+.include <bsd.port.pre.mk>
+.if ${PORTOBJFORMAT} == "aout"
+DISTNAME= pathchar-a0-freebsd-2.2
+PKGNAME= pathchar-a0
+MD5_FILE= ${FILESDIR}/md5.aout
+.endif
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+ZCAT?= zcat
+TAR?= tar
+
+# wierd .. pathchar-a0 is a gzip'd gzip'd tar, while pathchar-a1
+# is just a tar. both have the extension .tar.gz though...
+.if ${PORTOBJFORMAT} == "aout"
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @for file in ${EXTRACT_ONLY}; do \
+ if ! (cd ${WRKDIR} && ${ZCAT} ${DISTDIR}/$$file | \
+ ${TAR} ${EXTRACT_BEFORE_ARGS} - ${EXTRACT_AFTER_ARGS}); \
+ then \
+ exit 1; \
+ fi \
+ done
+.else
+EXTRACT_BEFORE_ARGS= -xf
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pathchar ${PREFIX}/bin
+ ${INSTALL_DATA} ${FILESDIR}/README.pathchar \
+ ${PREFIX}/share/doc/README.pathchar
+
+.include <bsd.port.post.mk>