aboutsummaryrefslogtreecommitdiff
path: root/net/pathneck/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-12-22 13:57:16 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-12-22 13:57:16 +0000
commit690047809068eac49f6662e81253051fe3967dc0 (patch)
tree2e9b6316e854dd6a669455b1f68cb4bdfc70ba11 /net/pathneck/Makefile
parentc5ef95cf146b9c4fbd9c2e374dc194f1f0e0beff (diff)
downloadports-690047809068eac49f6662e81253051fe3967dc0.tar.gz
ports-690047809068eac49f6662e81253051fe3967dc0.zip
Notes
Diffstat (limited to 'net/pathneck/Makefile')
-rw-r--r--net/pathneck/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/net/pathneck/Makefile b/net/pathneck/Makefile
new file mode 100644
index 000000000000..3edd51923515
--- /dev/null
+++ b/net/pathneck/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: pathneck
+# Date Created: 22 Dec 2005
+# Whom: Babak Farrokhi <babak@farrokhi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pathneck
+PORTVERSION= 1.2
+CATEGORIES= net
+MASTER_SITES= http://gs274.sp.cs.cmu.edu/www/pathneck/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= babak@farrokhi.net
+COMMENT= Active network path probing tool
+
+PLIST_FILES= sbin/pathneck \
+ sbin/get-choke
+PORTDOCS= COPYING ChangeLog README
+MAKEFILE= Makefile.bsd
+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^CC .=,CC ?=,' \
+ -e 's,^CFLAGS .=,CFLAGS +=,' \
+ ${WRKSRC}/Makefile.bsd
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pathneck ${PREFIX}/sbin/pathneck
+ ${INSTALL_PROGRAM} ${WRKSRC}/get-choke ${PREFIX}/sbin/get-choke
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>