aboutsummaryrefslogtreecommitdiff
path: root/net/pbnc
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-03 21:12:03 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-03 21:12:03 +0000
commitb59e0b0c7b840dbfcf137cab70d745601f6b4526 (patch)
tree128d3d11ec0447ea0920764dccb136fd1b20208b /net/pbnc
parent1fc6421d93fa418fa3aae8ce10bb591ac44503fa (diff)
downloadports-b59e0b0c7b840dbfcf137cab70d745601f6b4526.tar.gz
ports-b59e0b0c7b840dbfcf137cab70d745601f6b4526.zip
Notes
Diffstat (limited to 'net/pbnc')
-rw-r--r--net/pbnc/Makefile45
-rw-r--r--net/pbnc/distinfo2
-rw-r--r--net/pbnc/pkg-descr12
3 files changed, 59 insertions, 0 deletions
diff --git a/net/pbnc/Makefile b/net/pbnc/Makefile
new file mode 100644
index 000000000000..6db78f2b98ec
--- /dev/null
+++ b/net/pbnc/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: pbnc
+# Date created: 03 Apr 2004
+# Whom: hrs
+#
+# $FreeBSD$
+
+PORTNAME= pbnc
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://duncanthrax.net/pbnc/
+DISTNAME= pbnc
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Simple userspace TCP port bouncer
+
+RUN_DEPENDS= ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask
+
+NO_BUILD= yes
+PLIST= ${WRKSRC}/pkg-plist
+
+CONFIGDIR= etc
+CONFIG_FILES= pbnc.cfg
+SCRIPTDIR= bin
+SCRIPT_FILES= pbnc.pl
+DOC_FILES= pbnc.readme
+
+pre-install:
+ (${ECHO_CMD} "${CONFIGDIR}/${CONFIG_FILES}"; \
+ ${ECHO_CMD} "${SCRIPTDIR}/${SCRIPT_FILES}"; ) > ${PLIST}
+.if !defined(NOPORTDOCS)
+ (for F in ${DOC_FILES}; do \
+ ${ECHO_CMD} "${DOCSDIR:S,^${PREFIX}/,,}/$${F}"; \
+ done;\
+ ${ECHO_CMD} "@dirrm ${DOCSDIR:S,^${PREFIX}/,,}" ) >> ${PLIST}
+.endif
+
+do-install:
+ ${INSTALL_SCRIPT} ${SCRIPT_FILES:S,^,${WRKSRC}/,} ${PREFIX}/${SCRIPTDIR}
+ ${INSTALL_DATA} ${CONFIG_FILES:S,^,${WRKSRC}/,} ${PREFIX}/${CONFIGDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/pbnc/distinfo b/net/pbnc/distinfo
new file mode 100644
index 000000000000..48ff27074dd5
--- /dev/null
+++ b/net/pbnc/distinfo
@@ -0,0 +1,2 @@
+MD5 (pbnc.tar.gz) = 13b419ee101f2c45155818cc78326f42
+SIZE (pbnc.tar.gz) = 6018
diff --git a/net/pbnc/pkg-descr b/net/pbnc/pkg-descr
new file mode 100644
index 000000000000..3ebfa065949a
--- /dev/null
+++ b/net/pbnc/pkg-descr
@@ -0,0 +1,12 @@
+pbnc runs in userland and acts as a simple TCP port forwarder.
+It has a single-threaded design (uses select(), does not
+fork). It can handle multiple targets with an unlimited number
+of clients (at least in theory), and supports simple IP-based
+access control. Since pbnc works on network level, it does not
+care about the application protocol. It can tunnel FTP
+(control connection), SSH, HTTP and all other protocols using
+TCP communication. Application-level SSL/TLS encryption is
+also no problem.
+
+WWW: http://duncanthrax.net/pbnc/
+WWW: http://freshmeat.net/projects/pbnc/