aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_SMTP
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-27 09:52:24 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-27 09:52:24 +0000
commit6c945a556a2352c00456a10ffbb94155ab32efc8 (patch)
tree6878247bbc0881c2fda6fda4c66582014b9b6407 /net/pear-Net_SMTP
parent81db1ba729d36a0f488b5e02a7bd13e52343cc40 (diff)
Notes
Diffstat (limited to 'net/pear-Net_SMTP')
-rw-r--r--net/pear-Net_SMTP/Makefile46
-rw-r--r--net/pear-Net_SMTP/distinfo1
-rw-r--r--net/pear-Net_SMTP/pkg-comment1
-rw-r--r--net/pear-Net_SMTP/pkg-descr4
-rw-r--r--net/pear-Net_SMTP/pkg-plist3
5 files changed, 55 insertions, 0 deletions
diff --git a/net/pear-Net_SMTP/Makefile b/net/pear-Net_SMTP/Makefile
new file mode 100644
index 000000000000..74b63743fac1
--- /dev/null
+++ b/net/pear-Net_SMTP/Makefile
@@ -0,0 +1,46 @@
+# Ports collection makefile for: pear-Net_SMTP
+# Date created: 26 November 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_SMTP
+PORTVERSION= 1.1.1
+CATEGORIES= net mail www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR class that provides an implementation of the SMTP protocol
+
+BUILD_DEPENDS= ${PEARDIR}/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_BASE= ${LOCALBASE}
+.endif
+PEAR= ${LOCALBASE}/bin/pear
+LPHP_LIB= lib/php
+PEARDIR= ${LOCALBASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+MANIFEST= Net/SMTP.php
+
+do-install:
+ @${MV} ${PEARDIR}/${MANIFEST} ${PEARDIR}/${MANIFEST}.dist
+ @${CP} -p ${WRKSRC}/SMTP.php ${PEARDIR}/Net
+ @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${MANIFEST}
+
+post-install:
+# Register an upgraded package
+ @${PEAR} upgrade -r -f ${WRKDIR}/package.xml
+
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_SMTP/distinfo b/net/pear-Net_SMTP/distinfo
new file mode 100644
index 000000000000..71149e1640aa
--- /dev/null
+++ b/net/pear-Net_SMTP/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Net_SMTP-1.1.1.tgz) = 918b7419f1b1f374ce46313f1fac928d
diff --git a/net/pear-Net_SMTP/pkg-comment b/net/pear-Net_SMTP/pkg-comment
new file mode 100644
index 000000000000..0f34e2fbbc53
--- /dev/null
+++ b/net/pear-Net_SMTP/pkg-comment
@@ -0,0 +1 @@
+PEAR class that provides an implementation of the SMTP protocol
diff --git a/net/pear-Net_SMTP/pkg-descr b/net/pear-Net_SMTP/pkg-descr
new file mode 100644
index 000000000000..ace9ff315210
--- /dev/null
+++ b/net/pear-Net_SMTP/pkg-descr
@@ -0,0 +1,4 @@
+This PEAR class provides an implementation of the SMTP protocol using PEAR's
+Net_Socket:: class.
+
+WWW: http://pear.php.net/package-info.php?pacid=90
diff --git a/net/pear-Net_SMTP/pkg-plist b/net/pear-Net_SMTP/pkg-plist
new file mode 100644
index 000000000000..87398a599255
--- /dev/null
+++ b/net/pear-Net_SMTP/pkg-plist
@@ -0,0 +1,3 @@
+@exec mv %D/lib/php/Net/SMTP.php %D/lib/php/Net/SMTP.php.dist
+%%PEARDIR%%/Net/SMTP.php
+@unexec mv %D/lib/php/Net/SMTP.php.dist %D/lib/php/Net/SMTP.php || true