aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_Server/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-28 19:18:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-28 19:18:26 +0000
commit96e224570458896f04563eea4ba0baa644362bc9 (patch)
tree0286c13325fa1298388b13118f522480548fb113 /net/pear-Net_Server/Makefile
parent82f73ba949eeb2dab729a5d41ff6235b14086551 (diff)
downloadports-96e224570458896f04563eea4ba0baa644362bc9.tar.gz
ports-96e224570458896f04563eea4ba0baa644362bc9.zip
Notes
Diffstat (limited to 'net/pear-Net_Server/Makefile')
-rw-r--r--net/pear-Net_Server/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/pear-Net_Server/Makefile b/net/pear-Net_Server/Makefile
new file mode 100644
index 000000000000..2d7f88da7e1b
--- /dev/null
+++ b/net/pear-Net_Server/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: pear-Net_Server
+# Date created: 23 Octobre 2004
+# Whom: Gerrit Beine (<tux@pinguru.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Server
+PORTVERSION= 0.12.0
+CATEGORIES= net pear
+
+MAINTAINER= tux@pinguru.net
+COMMENT= Generic server class
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= sockets pcntl
+CATEGORY= Net
+FILES= Server.php \
+ Server/Driver.php Server/Handler.php \
+ Server/Driver/Fork.php Server/Driver/Sequential.php
+DOCS= todo.txt
+EXAMPLES= talkback.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>