aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_Sieve
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-02-24 05:27:41 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-02-24 05:27:41 +0000
commit37408314394e95028d8b2c39c7a046743f4a8aff (patch)
tree2b6191d95df05d3c803b2b608388da8da19d5172 /net/pear-Net_Sieve
parente9cbac30476d2a2b80b9d5e2de2698408bade36d (diff)
downloadports-37408314394e95028d8b2c39c7a046743f4a8aff.tar.gz
ports-37408314394e95028d8b2c39c7a046743f4a8aff.zip
Notes
Diffstat (limited to 'net/pear-Net_Sieve')
-rw-r--r--net/pear-Net_Sieve/Makefile14
-rw-r--r--net/pear-Net_Sieve/pkg-deinstall13
2 files changed, 24 insertions, 3 deletions
diff --git a/net/pear-Net_Sieve/Makefile b/net/pear-Net_Sieve/Makefile
index 0fe25d7c9ed7..a88805f04d3b 100644
--- a/net/pear-Net_Sieve/Makefile
+++ b/net/pear-Net_Sieve/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net_Sieve
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= http://pear.php.net/get/
PKGNAMEPREFIX= pear-
@@ -16,8 +17,8 @@ DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR class to handle talking to timsieved
-BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
-RUN_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
NO_BUILD= yes
@@ -25,14 +26,21 @@ NO_BUILD= yes
.if exists(${LOCALBASE}/bin/php-config)
PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_BASE!= ${LOCALBASE}
.endif
+PEAR= ${LOCALBASE}/bin/pear
LPHP_LIB= lib/php
PEARDIR= ${PHP_BASE}/${LPHP_LIB}
PLIST_SUB= PEARDIR=${LPHP_LIB}
do-install:
@${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Net
- @${CHOWN} root:wheel ${PEARDIR}/Net/Sieve.php
+ @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Net/Sieve.php
@${CHMOD} a-x ${PEARDIR}/Net/Sieve.php
+post-install:
+# Register a new package
+ @${PEAR} install -r -f ${WRKDIR}/package.xml
+
.include <bsd.port.post.mk>
diff --git a/net/pear-Net_Sieve/pkg-deinstall b/net/pear-Net_Sieve/pkg-deinstall
new file mode 100644
index 000000000000..c17e9d19ced0
--- /dev/null
+++ b/net/pear-Net_Sieve/pkg-deinstall
@@ -0,0 +1,13 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Remove package declaration from PEAR's registry.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+PKG_NAME=${1%%-[0-9._]*}
+PACKAGE=$(echo $PKG_NAME | sed 's/pear-//')
+
+${PKG_PREFIX}/bin/pear uninstall -r ${PACKAGE} || true