aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_Socket/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
commit077b4b53b0d0814df73a850dfa8625101c7b8404 (patch)
tree1635d75a5b1ebd11d644c2d01607580c9063de35 /net/pear-Net_Socket/Makefile
parent95cfdcc8b6a9c07b40477662aa446e3bdd99525b (diff)
downloadports-077b4b53b0d0814df73a850dfa8625101c7b8404.tar.gz
ports-077b4b53b0d0814df73a850dfa8625101c7b8404.zip
Notes
Diffstat (limited to 'net/pear-Net_Socket/Makefile')
-rw-r--r--net/pear-Net_Socket/Makefile22
1 files changed, 6 insertions, 16 deletions
diff --git a/net/pear-Net_Socket/Makefile b/net/pear-Net_Socket/Makefile
index f9456bbc492a..b9ee878428e4 100644
--- a/net/pear-Net_Socket/Makefile
+++ b/net/pear-Net_Socket/Makefile
@@ -7,31 +7,21 @@
PORTNAME= Net_Socket
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= net www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR Network Socket Interface
-BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
-RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
-
-NO_BUILD= yes
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.endif
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
do-install:
+ @${MKDIR} ${PEARDIR}/Net
@${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Net
- @${CHOWN} -R root:wheel ${PEARDIR}/Net/Socket.php
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Net
.include <bsd.port.post.mk>