aboutsummaryrefslogtreecommitdiff
path: root/net/pear-Net_UserAgent_Detect
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-01-09 04:59:35 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-01-09 04:59:35 +0000
commitcb9b5a9552dc85d0706aec97190d0ee4765f658b (patch)
tree08ed67526ab66f77d418da52c28a83fc0e6264db /net/pear-Net_UserAgent_Detect
parentfff3444f063e191c93bb519d308ecb65fb2529a0 (diff)
downloadports-cb9b5a9552dc85d0706aec97190d0ee4765f658b.tar.gz
ports-cb9b5a9552dc85d0706aec97190d0ee4765f658b.zip
Notes
Diffstat (limited to 'net/pear-Net_UserAgent_Detect')
-rw-r--r--net/pear-Net_UserAgent_Detect/Makefile32
-rw-r--r--net/pear-Net_UserAgent_Detect/distinfo2
-rw-r--r--net/pear-Net_UserAgent_Detect/pkg-descr10
3 files changed, 44 insertions, 0 deletions
diff --git a/net/pear-Net_UserAgent_Detect/Makefile b/net/pear-Net_UserAgent_Detect/Makefile
new file mode 100644
index 000000000000..0b4999f5c412
--- /dev/null
+++ b/net/pear-Net_UserAgent_Detect/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: pear-Net_UserAgent_Detect
+# Date created: 04 January 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_UserAgent_Detect
+PORTVERSION= 2.0.1
+CATEGORIES= net pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class that detects web browser, version and platform
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+
+CATEGORY= Net/UserAgent
+FILES= Detect.php
+
+.include <bsd.port.pre.mk>
+
+PHP_VERS= ${PHP_VERSION:S/.//g}
+
+.if defined(PHP_VERS) && ${PHP_VERS} < 410
+IGNORE= "You need PHP 4.1.0 or later to install PEAR::Net_UserAgent_Detect"
+.endif
+
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/net/pear-Net_UserAgent_Detect/distinfo b/net/pear-Net_UserAgent_Detect/distinfo
new file mode 100644
index 000000000000..a828c9b8796b
--- /dev/null
+++ b/net/pear-Net_UserAgent_Detect/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Net_UserAgent_Detect-2.0.1.tgz) = b49c6a19b220d674db4355bdab3498e5
+SIZE (PEAR/Net_UserAgent_Detect-2.0.1.tgz) = 8230
diff --git a/net/pear-Net_UserAgent_Detect/pkg-descr b/net/pear-Net_UserAgent_Detect/pkg-descr
new file mode 100644
index 000000000000..7c6a69756e73
--- /dev/null
+++ b/net/pear-Net_UserAgent_Detect/pkg-descr
@@ -0,0 +1,10 @@
+The Net_UserAgent object does a number of tests on an HTTP user
+agent string. The results of these tests are available via methods of
+the object.
+
+This module is based upon the JavaScript browser detection code available
+at http://www.mozilla.org/docs/web-developer/sniffer/browser_type.html.
+This module had many influences from the lib/Browser.php code in
+version 1.3 of Horde.
+
+WWW: http://pear.php.net/package/Net_UserAgent_Detect/